Jubiläums-Berechnungen in Excel

12. Februar 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Stelle Sie sich eine Mitarbeiterliste vor, in der Sie alle Mitarbeiter, die 50 Jahre oder älter sind, mit einem Hinweistext markieren möchten, um ihnen zum Geburtstag eine Karte zu schicken.

Für die Lösung dieser Aufgabe erst einmal ein Wort zum Hintergrund der Datenverarbeitung von Excel: Datumsangaben werden in Excel abhängig vom Startdatum 1. Januar 1900 intern als fortlaufende Zahlen behandelt.

Wenn Sie also einfach das Geburtsdatum vom heutigen Datum subtrahieren und überprüfen möchten, ob es größer als 50 ist, so wird das nicht funktionieren. Denn für Excel steht für 50 Jahre die Zahl 18262 (das ist das Datum 30. 12. 1949) und somit wären alle Personen in Ihrer Tabelle älter als 50 Jahre, denn 18262 ist größer als 50.

Warum der 30. 12. 1949 und nicht der 31. 12. 1949? Weil die Rechnung in Excel für den 1. 1. 1900 mit der Zahl Eins beginnt und gleichgesetzt wird. Somit muss man diese Eins also bei der Rechnung erst einmal wieder abziehen.

Vor diesem Hintergrund ist die Berechnung des Alters eigentlich sehr einfach:

     

  1. Sie geben in einer Zelle das Geburtsdatum Ihres Mitarbeiters ein, z. b. in der Zelle B2.
  2. Dann geben Sie in der Zelle daneben, also C2, die Formel für das aktuelle Datum ein. Das erledigen Sie am besten mit der Funktion HEUTE().
  3. In die Zelle D2 tragen Sie anschließend das Datum 30. 12. 1949 ein. Das sind die 50 Jahre, die Sie subtrahieren wollen.
  4. In der Zelle E2 tragen Sie nun die folgende Formel ein:
  5.  

=WENN(C2->=D2;"50 oder älter";"noch nicht 50")

Mit dieser Formel werden alle Mitarbeiter, die heute oder davor 50 Jahre alt geworden sind, mit dem Text "50 oder älter" markiert, alle anderen mit "noch nicht 50".

Falls Sie auf die zweite Angabe verzichten und nur die Mitarbeiter markiere möchten, die 50 Jahre oder älter sind, dann lassen Sie die Sonst-Bedingung in der WENN-Abfrage weg. Die Formel sieht dann so aus:

=WENN(C2-B2>=D2;"50 oder älter";"")

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"