Nummerierung einer Excel-Liste abhängig von den Inhalten der Nachbarzelle durchführen

23. Juni 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Machen Sie Nummerierung einer Excel-Liste davon abhängig, was sich in einer bestimmten Spalte befindet und vergeben Sie Nummern nur bei Zellen, die nicht leer sind

Wie Sie eine Nummerierung in Spalte A per Formel durchführen

Wie Sie eine Nummerierung in Spalte A per Formel durchführen

In einer Excel-Tabelle soll in der Spalte A eine fortlaufende Nummerierung erscheinen. Allerdings nur, wenn in der entsprechenden Zeile in der Spalte ein Wert steht. Steht in der Spalte B kein Wert, soll diese Zeile nicht mitgezählt werden. Die folgende Abbildung zeigt eine Beispieltabelle:

Diese Beispieltabelle soll nummeriert werden

Zur Lösung dieser Aufgabe verwenden Sie eine WENN-Abfrage, die überprüft, ob die entsprechende Zelle in der Spalte B einen Wert enthält.

Wenn ja, wird mit der Funktion ANZAHL2 die Anzahl der mit Inhalten gefüllten Zellen oberhalb der aktuellen Zeile ausgegeben, ansonsten eine leere Zelle.

Für diese Abfrage tragen Sie die folgende Formel in die Zelle A2 ein:

=WENN($B2<>"";ANZAHL2($B2:$B$2);"")

Anschließend erscheint in der Zelle A2 der Wert 1. Diese Formel kopieren Sie dann durch Ziehen mit der Maus in die darunterliegenden Zellen der Spalte A.

Die folgende Abbildung zeigt einen Ausschnitt aus der Beispieltabelle, in der dank obiger Formel die Zeilen 4, 7 und 10 nicht nummeriert sind:

Wie Sie eine Nummerierung in Spalte A per Formel durchführen

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"