So machen Sie Berechnungen von Wochentagen abhängig

01. August 2016
Martin Althaus Von Martin Althaus, Excel, Office ...

Viele Listen oder Tabellen enthalten neben Zahlen auch noch Datumswerte. Um solche datumsabhängigen Zahlen besser bewerten zu können, hilft Ihnen eine spezielle Matrixformel weiter. Mit dieser Matrixformel berechnen Sie für jede Zeile der Liste den Mittelwert des jeweils aufgeführten Datums.

Wenn es sich bei dem Datum in einer Zeile also beispielsweise um einen Montag handelt, bildet die Formel dort den Mittelwert aller Montage der Liste. So haben Sie sofort einen Überblick, wie Sie die Werte einer bestimmten Zeile einschätzen müssen, da Sie den Mittelwert der entsprechenden Wochentage sofort sehen können. Die folgende Matrixformel erledigt diese Berechnung für Sie:

=MITTELWERT(WENN(WOCHENTAG(Datum)=WOCHENTAG(Daten);Werte;ʺʺ))

Sie übergeben der Matrixformel drei Argumente. Mit Datum übergeben Sie das Datum, für dessen Wochentag Sie den Mittelwert berechnen möchten. Über das Argument Daten übergeben Sie den Bereich mit den Datumswerten, deren Wochentage für die Berechnung relevant sind. Das dritte Argument Werte übergibt die zu den Datumswerten gehörenden Werte, für die Sie den Mittelwert in Abhängigkeit vom Wochentag des dazugehörenden Datums berechnen möchten.

Übergeben Sie Daten als absoluten Bezug, damit er beim Kopieren der Formel nicht angepasst wird. Bestätigen Sie die Formel nach der Eingabe über Strg+Umschalt+Eingabe, da es sich um eine Matrixformel handelt.

Als Ergebnis liefert die Formel den Mittelwert aller Werte, deren dazugehörendes Datum denselben Wochentag aufweist wie das übergebene Datum. In der abgebildeten Tabelle liefert die folgende Formel in Zelle C4 als Ergebnis den Wert 75:

=MITTELWERT(WENN(WOCHENTAG(A4)=WOCHENTAG($A$4:$A$16);$B$4:$B$16;ʺʺ))

Die Formel ermittelt im Bereich B4:B16 den Mittelwert aller Zeilen, die im Bereich A4:A16 denselben Wochentag aufweisen wie das Datum aus Zelle A4. Dies trifft mit einem Freitag nur auf die Zeilen 4 und 11 zu. Der Mittelwert der beiden Zahlen 100 und 50 lautet 75.

So ermittelt die Matrixformel den gesuchten Mittelwert

Um den Mittelwert anhand des Wochentags zu ermitteln, setzt die Formel die folgende Methode ein:

  • Die erste WOCHENTAG-Funktion ermittelt den Wochentag des übergebenen Datums.
  • Diesen vergleicht die zweite WOCHENTAG-Funktion mit jedem Wochentag des Datumsbereichs.
  • Falls eine Übereinstimmung vorliegt, übergibt die WENN­Funktion den entsprechenden Wert aus dem Wertebereich an die MITTELWERT-Funktion.
  • Liegt keine Übereinstimmung vor, wird von der WENN-Funktion ein Leer­/String übergeben.

Anstelle des Mittelwerts können Sie über diese Formel auch eine andere statistische Berechnung durchführen. Ersetzen Sie dazu die MITTELWERT-Funktion durch eine andere statistische Tabellenfunktion.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"