Zeiten in Excel-Tabellen nach Wochentagen auswerten und zusammenfassen

04. Juni 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Machen Sie Auswertungen davon abhängig, zu welchen Wochentagen die Zahlen gehören, die Sie auswerten möchten.

Nur noch die Zeiten, die auf einen Dienstag fallen

Nur noch die Zeiten, die auf einen Dienstag fallen

Stellen Sie sich eine Liste vor, in der Sie zu Datumsangaben Arbeitszeiten erfassen. In dieser Tabelle soll nun die Arbeitszeit addiert werden, die an einem bestimmten Wochentag geleistet wurde. Die folgende Abbildung zeigt eine solche Erfassungstabelle:

Datumswerte und dazugehörige Zeiten

In der Tabelle sind Tage und dazugehörige Zeiten erfasst. Nun sollen nur die Arbeitszeiten addiert werden, die an einem Dienstag geleistet wurden.

Für die Addition benötigen Sie eine Hilfsspalte, in der die Wochentage einzeln dargestellt werden. Diese legen Sie rechts neben der Spalte A an. Da in der Spalte B die Stunden stehen, fügen Sie zwischen den beiden Spalten die Hilfsspalte ein. Klicken Sie dazu mit der rechten Maustaste auf den Spaltenbuchstaben B und wählen Sie die Funktion "Zellen einfügen".

In dieser Spalte ermitteln Sie mit der Funktion WOCHENTAG die entsprechenden Tage für die Datumsangaben in der Spalte A. Der Funktion WOCHENTAG übergeben Sie als Argumente die Zellen der Spalte A und die Option "2". Diese bewirkt, dass die Woche mit dem Montag als erstem Tag beginnt.

Als Ergebnis liefert die Funktion WOCHENTAG nicht den Namen des Tages, sondern die Tageszahl, 1 für Montag, 2 für Dienstag usw. In Zelle B1 tragen Sie ein:

=WOCHENTAG(A1;2)

Die folgende Abbildung zeigt die Ermittlung der Wochentage in der Tabelle:

Zu jedem Datum der Wochentag

Wenn Sie nun wissen wollen, wie viel an den Montagen gearbeitet wurde, verwenden Sie die Funktion SUMMEWENN. Mit dieser Funktion können Sie nach einem bestimmten Kriterium innerhalb eines Bereichs suchen und wenn dieses Kriterium gefunden wird, werden die dazugehörigen Werte addiert.

Für das vorliegende Beispiel sollen die Arbeitszeiten für alle Montage addiert werden. Die Formel dafür sieht folgendermaßen aus:

=SUMMEWENN(B1:B20;2;C1:C20)

Diese Formel arbeitet so: Sie durchsucht die Zellen B1 bis B20. Wenn sie dort den Wert "2" (entspricht Montag) findet, werden die dazugehörigen Zellen aus der Spalte C addiert.

Damit das Formelergebnis in der gewünschten Form angezeigt wird, müssen Sie die Zelle formatieren. Klicken Sie dazu die Zelle an und drücken Sie die Tastenkombination STRG 1.

In der Dialogbox ZELLEN FORMATIEREN weisen Sie der Zelle in der Kategorie UHRZEIT das Format "37:30:55" zu. Das Ergebnis der Addition sieht in der Tabelle folgendermaßen aus:

Nur noch die Zeiten, die auf einen Dienstag fallen

Wenn Sie nun die Arbeitsstunden für alle Montage errechnen wollen, ist das ganz einfach: Sie tauschen nur den Wert 1 in der Formel durch 1 aus, also:

=SUMMEWENN(B1:B20;1;C1:C20)

Für die anderen Tage der Woche verwenden Sie die entsprechenden Werte von 3 bis 7.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"