Calc: Wie oft kommt ein Bestimmter Wert vor?

28. Juli 2015
Achim Wagenknecht Von Achim Wagenknecht, Freeware & Open Source, News & Trends, Linux, OpenOffice, Picasa, GIMP, Multimedia ...

Die Funktion ZählenWenn zählt, wie oft eine bestimmte Bedingung in einem Bereich vorkommt.

Windows+Linux / Deutsch / Open Source. Wie viele Schüler kommen aus Wuppertal? Wie oft war der Kontostand unter Null? Zu wie vielen Zeitpunkten war die Maschine überlastet? Solche und ähnliche Fragen können Sie in LibreOffice Calc mit der Funktion ZählenWenn beantworten.

Nehmen wir an, in der Adressenliste einer Schule ist in Spalte C die Stadt aufgeführt. Dann ermitteln Sie mit folgender Formel, wie viele Schüler aus Wuppertal kommen:

=ZÄHLENWENN(C$2:C10000;"Wuppertal")

Die Zählung fängt im Beispiel in der Zelle C2 an, weil in der ersten Zeile eine Überschrift steht. Für das Ende der Zählung müssen Sie eine Zeile angeben, die auf jeden Fall größer als die Gesamtzahl der befüllten Zeilen ist, weil man in Calc leider immer noch keine ganzen Spalten in Formeln eintragen kann. Die Bedingung wird immer in Anführungszeichen gesetzt. Soll die Bedingung eine einfache Wortgleichheit sein, so genügt es, das Wort in Anführungszeichen einzutragen.

Wenn Sie in einem Kontoauszug zählen möchten, wie oft der Kontostand unter Null war, benutzen Sie folgende Formel:

=ZÄHLENWENN(A$1:A100;"<0")

Setzen Sie statt des Kleinerzeichens das Größerzeichen ein und statt der Null den Grenzwert der überlasteten Maschine, so können Sie auch die dritte Frage beantworten:

=ZÄHLENWENN(A$1:A100;">123")

Und was ist mit den Schülern, die nicht aus Wuppertal kommen? Die finden Sie mit dieser Formel:

=ZÄHLENWENN(C$2:C102;"<>Wuppertal")

Sie können an dieser Stelle auch reguläre Ausdrücke verwenden. Damit zählen Sie nicht eine bestimmte Zeichenfolge, sondern allgemeinere Bedingungen. Die folgende Formel zählt zum Beispiel alle Einträge, die mit S beginnen:

=ZÄHLENWENN(C$2:C101;"S.*")

So nutzen Sie endlich alle Office-Möglichkeiten!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Windows-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"