So summieren Sie Kategorien in Calc

08. März 2012
Achim Wagenknecht Von Achim Wagenknecht, Freeware & Open Source, News & Trends, Linux, OpenOffice, Picasa, GIMP, Multimedia ...

Oft sind Zahlen nach Kategorien geordnet, zum Beispiel in Kontoauszügen. So bilden Sie die dazugehörigen Summen.

Was haben wir für Lebensmittel ausgegeben? Und wie viel für Benzin? Die Antworten auf diese und ähnliche Fragen erhalten Sie, wenn Sie Ihre Kontoauszüge mit LibreOffice Calc nach Kategorien auswerten. Sie können dazu in Calc Summen bilden, in die Zahlen nur unter bestimmten Bedingungen eingehen. So lassen sich zum Beispiel alle Ausgaben summieren, aber nur, wenn daneben das Wort „Lebensmittel“ steht. Auf diese Weise erhalten Sie aus Kontoauszügen im Handumdrehen die Summen über die einzelnen Kategorien.

Dazu brauchen Sie zwei Spalten: Eine mit den Beträgen und eine mit den dazugehörigen Kategorien. Nehmen wir an, die Beträge stehen in Spalte A und die Kategorien in Spalte B. Dann können Sie mit folgender Formel eine bedingte Summe bilden:
=SUMMEWENN(B2:B64000;“=Lebensmittel“;A2:A64000)

Und das bedeuten die einzelnen Bestandteile der Formel:

=SUMMEWENN(
Das Gleichheitszeichen zeigt Calc, dass hier eine Formel kommt. „Summewenn“ ist der Name der Funktion. Danach folgen in Klammern drei Argumente.

B2:B64000
In diesem Zellbereich steht die Bedingung. Da die Spalte eine Überschrift hat, fängt der Bereich erst in Zeile 2 an. Und weil man in Calc keine ganze Spalte in eine Formel einfügen kann, behilft man sich mit einem sehr großen Zellbereich, der hier erst in Zeile 64000 endet.

;
Das Semikolon trennt die drei Argumente der Formel.

“=Lebensmittel“
Das ist die Bedingung. Nur wenn der Inhalt der entsprechenden Zelle „Lebensmittel“ lautet, wird die Summe gebildet.

A2:A64000
Der Zellbereich, der aufsummiert werden soll, steht am Schluss der Formel.

Kopieren Sie die Formel für jede Kategorie und tragen Sie jeweils den Namen der Kategorie als mittleres Argument ein.

So nutzen Sie endlich alle Office-Möglichkeiten!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Windows-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"