So zählen Sie das Auftreten eines Wochentages in einem bestimmten Monat
So zählen Sie das Auftreten eines Wochentages in einem bestimmten Monat

Anzahl eines bestimmen Wochentags in einem Monat mit Excel zählen

So zählen Sie mit Excel, wie oft ein bestimmter Wochentag in einem Monat vorkommt

Sie möchten ermitteln, wie oft ein bestimmter Wochentag in einem Monat Ihrer Wahl vorkommt? Das kann zum Beispiel sinnvoll sein, um Abrechnungen zu erstellen oder Projekt zu planen.

Die folgende Tabelle zeigt die Ausgangssituation. In Zelle B1 steht eine Jahreszahl (hier 2012). In Zelle B2 steht eine Monatsnummer (hier 8 für August). In Zelle B3 befindet sich die Nummer des gesuchten Wochentages. Die Zahl 1 steht für den Montag, die 2 für den Dienstag, bis zur 7 für den Sonntag. Mit dem Wert von 3 in Zelle B3 wird das Auftreten des Mittwochs gezählt.

Sie möchten feststellen, wie oft ein bestimmter Wochentag in einen Monat vorkommt

Um festzustellen, wie oft der Wochentag au

Verwenden Sie in Zelle B4 die folgende Formel, um die Berechnung auszuführen:

=SUMMENPRODUKT(1*(WOCHENTAG(DATUM(B1;B2;ZEILE(INDIREKT("1:"&TAG(DATUM(B1;B2+1;0)))));2)=B3))

Bei der Formel handelt es sich um eine Matrixformel. Geben Sie die Formel über die Tastenkombination STRG UMSCHALT EINGABE ein. Mit der Taste UMSCHALT ist die Taste gemeint, die Sie gedrückt halten, um einen Großbuchstaben einzugeben. Auch nach jeder Änderung der Formel  verwenden Wie zur Bestätigung wieder die Tastenkombination STRG UMSCHALT EINGABE. Wenn Sie die Formel  nur mit der Eingabetaste eintragen, erhalten Sie die Fehlermeldung #WERT!.

Die folgende Abbildung zeigt den Einsatz der Formel in der Praxis:

So zählen Sie das Auftreten eines Wochentages in einem bestimmten Monat

Es werden alle Tage in dem entsprechenden Monat berücksichtigt, vom Monatsersten bis zum Monatsletzten.