Zeiten nur an bestimmten Tagen addieren

Zeiten nur an bestimmten Tagen addieren

Wie Sie Zeitberechnungen von Wochentagen abhängig machen

Stellen Sie sich eine Tabelle vor, in der Sie zu Datumsangaben Arbeitszeiten erfassen. In dieser Tabelle soll nun die Arbeitszeit addiert werden, die an einem bestimmten Wochentag geleistet wurde. Die folgende Abbildung zeigt eine solche Erfassungstabelle:

Im vorliegenden Beispiel sollen die Arbeitszeiten addiert werden, die an einem Montag geleistet wurden.

Für die Addition setzen Sie eine Hilfsspalte ein, in der die Wochentage einzeln dargestellt werden. Diese legen Sie rechts neben der Spalte A an. Da in der Spalte B die Stunden stehen, fügen Sie zwischen den beiden Spalten die Hilfsspalte ein.

In dieser Spalte ermitteln Sie mit der Funktion WOCHENTAG die entsprechenden Tage für die Datumsangaben in der Spalte A.

Der Funktion WOCHENTAG übergeben Sie als Argumente die Zellen der Spalte A und die Option "2". Diese bewirkt, dass die Woche mit dem Montag als erstem Tag beginnt.

Als Ergebnis liefert die Funktion WOCHENTAG nicht den Namen des Tages, sondern die Tageszahl, 1 für Montag, 2 für Dienstag u. s. w. Die folgende Abbildung zeigt die Ermittlung der Wochentage in der Tabelle:

Wenn Sie nun wissen wollen, wie viel an den Montagen gearbeitet wurde, verwenden Sie dafür die Funktion SUMMEWENN.

Mit dieser Funktion können Sie nach einem bestimmten Kriterium innerhalb eines Bereichs suchen und wenn dieses Kriterium gefunden wird, werden die dazugehörigen Werte addiert.

Für das vorliegende Beispiel sollen die Arbeitszeiten für alle Montage addiert werden. Die Formel dafür sieht folgendermaßen aus:

=SUMMEWENN(B1:B20;1;C1:C20)

Diese Formel arbeitet so: Sie durchsucht die Zellen B1 bis B20. Wenn sie dort den Wert "1" (entspricht Montag) findet, werden die dazugehörigen Zellen aus der Spalte C addiert.

Damit das Formelergebnis in der gewünschten Form angezeigt wird, müssen Sie die Zelle formatieren.

 

Über die Dialogbox "Format – Zellen formatieren" weisen Sie der Zelle in der Kategorie "Uhrzeit" das Format "37:30:55" zu. Das Ergebnis der Addition sieht in der Tabelle folgendermaßen aus:

Wenn Sie nun die Arbeitsstunden für alle Dienstage errechnen wollen, ist das ganz einfach: Sie tauschen nur den Wert 1 in der Formel durch 2 aus, also:

=SUMMEWENN(B1:B20;2;C1:C20)

Für die anderen Tage der Woche verwenden Sie die entsprechenden Werte von 3 bis 7.