Addition von Excel-Werten an einen variablen Vergleichswert knüpfen

30. Juni 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Addieren Sie über eine variable Summe mit der Funktion SUMMEWENN nur die Zahlen, die über einem Grenzwert liegen, der in einer anderen Zelle definiert wird

So richten Sie einen variablen Vergleichswert für eine bedingte Summe ein

So richten Sie einen variablen Vergleichswert für eine bedingte Summe ein

In einer Tabelle sollen im Zellbereich B1:B10 nur die Werte addiert werden, wenn der Wert in der entsprechenden Zeile im Zellbereich A1:10 einen bestimmten Wert überschreitet – beispielsweise 10.000.

Die Lösung dieser Aufgabe ist mit der folgenden Formel recht einfach:

=SUMMEWENN(A1:A10;">10000";B1:B10)

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

Wie Sie eine bedingte Addition durchführen

Komplizierter wird es, wenn Sie den Vergleichswert (im Beispiel: > 10000) variabel gestalten wollen. Der Vergleichswert soll von der Formel aus der Zelle D3 entnommen werden.

Das Einsetzen der Zelladresse als Vergleichswert in der Form ">A6" führt in diesem Fall nicht zum gewünschten Ergebnis. Das liegt daran, dass Excel den Teil der Formel als Zeichenkette interpretiert.

Dieses Problem lösen Sie dadurch, dass Sie den Vergleichsoperator > mit dem kaufmännischen Und-Zeichen in der Form ">"&D3 mit der Zelladresse verknüpfen.

Excel erkennt dann, dass es sich bei der Zelladresse um einen Bezug handelt, und verknüpft den Vergleichsoperator mit dem Inhalt der Zelle D3.

Gemäß der beschriebenen Vorgehensweise sieht die komplette Formel in Zelle D3 so aus:

=SUMMEWENN(A1:A10;">"&D3;B1:B10)

Die folgende Abbildung zeigt die Formel im praktischen Einsatz in der Beispieltabelle:

So richten Sie einen variablen Vergleichswert für eine bedingte Summe ein

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"