Bereiche aus Excel-Zellen auslesen

19. Juni 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So legen Sie in Excel Formeln an, in den die Bereiche variabel sind

Wenn Sie in Ihren Formeln Berich verarbeiten, ist es normalerweise so, dass Sie den Bereich explizit in der Formel angeben, beispielsweise:

=SUMME(B2:B13)

Sobald Sie die Formel erweitern oder mit einem anderen Bereich einsetzen möchten, ist es erforderlich, den Bezug in der Formel anzupassen.

Es geht aber auch anders. Sie können den Bezug in der Formel (hier also: B2:B13) in eine andere Zelle schreiben und über eine INDIREKT-Funktion auf diese Zelle zugreifen. Die folgende Abbildung zeigt ein Beispiel dieser Technik:

rtemagicc_20080619-1bmp.jpg

In Zelle D2 wird die Summe der Zellen B2:B13 gebildet. Das geschieht aber nicht durch eine SUMME-Funktion, in der der Bezug direkt angegeben wird. Stattdessen lautet die Formel für Zelle D2:

=SUMME(INDIREKT(D1))

Die INDIREKT-Funktion sorgt dafür, dass der Bezug für die SUMME-Funktion aus der Zelle D1 übernommen wird. Hier steht der Ausdruck B2:B13, daher wird dieser Bezug in der Formel verwendet.

Wenn sich der Bereich für die Summenbildung verändert, können Sie neuen Bereich einfach in Zelle D1 anpassen.

Die INDIREKT-Funktion eignet sich besonders dafür, Bereiche, deren Umfang erst per Formel ermittelt wird, in anderen Funktionen einzusetzen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"