Eine dynamische Summe bilden

16. Januar 2018
Martin Althaus Von Martin Althaus, Excel, Office ...

Im folgenden Beispiel liegt Ihnen eine Tabelle mit Umsätzen vor. Diese Tabelle wird täglich erweitert, indem neue Zeilen jeweils am Ende der Liste hinzugefügt werden.

Standardmäßig wird dadurch die Summenfunktion in einer beliebigen Zelle nicht automatisch erweitert, wenn neue Daten in der Liste angefügt werden. Diesen Effekt können Sie über die Verwendung eines Bereichsnamens im Zusammenspiel mit einer Formel umgehen. Sie möchten schließlich vermeiden, aufgrund einer nicht angepassten Formel Ihren Vorgesetzten diverse Abweichungen im Budget erklären zu müssen.

Sehen Sie sich zunächst die folgende Abbildung an:

Wenn Sie die Summenfunktion in Zelle E4 mit der Formel =SUMME(B5:B20) erfassen, wird diese Formel leider nicht erweitert, wenn Sie am Ende der Liste neue Daten hinzufügen.

Durch einen Trick, den nicht viele kennen, bringen Sie Excel jedoch dazu, einen dynamischen Bereich zu erstellen. Dabei verfahren Sie wie folgt:

 

  1. Markieren Sie zunächst den Zellbereich B5:B20
  2. Tippen Sie ins Namensfeld links oben den Namen Umsätze und bestätigen Sie mit Eingabe. 

  3. Drücken Sie die Tastenkombination Strg+F3, um den Namensmanager aufzurufen. 

  4. Im erscheinenden Dialogfenster markieren Sie den Namen Umsätze
  5. Im Feld Bezieht sich auf erfassen Sie folgende Formel: =BEREICH.VERSCHIEBEN($B$5;0;0;ANZAHL2 ($B$5:$B$10000);1) 

  6. Bestätigen Sie mit einem Klick auf das Hakensymbol und klicken Sie anschließend auf Schließen. 

  7. Erfassen Sie in Zelle E4 die Formel =SUMME(Umsätze) und bestätigen Sie mit Eingabe. 


Wenn Sie am Ende der Liste neue Daten erfassen, wird die Formel in Zelle E4 automatisch angepasst. Die eigentliche Verschiebung des Bereichs beginnt in Zelle B5.

Mithilfe der Tabellenfunktion ANZAHL2() ermitteln Sie die mit Zahlen gefüllten Zellen im Zellbereich B5:B10000. Das Ergebnis der Funktion ANZAHL2() stellt dabei die Höhe der Verschiebung dar. Da die Verschiebung in einer Spalte vor sich gehen soll, wird im letzten Argument der Wert 1 angegeben.

Die Syntax lautet:

=BEREICH.VERSCHIEBEN(Bezug; Zeilen; Spalten;[Höhe]; [Breite])

Werden Sie mit unseren Tipps zum Excel-Profi!
Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Qualitätsstandard E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"