Einmaliges oder mehrmaliges Auftreten von Werten in Excel-Listen zählen

18. November 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Alle Werte zählen, die genau ein Mal, genau zwei Mal etc. auftreten

Stellen Sie sich eine Tabelle vor, in der im Zellbereich A1:A235 verschiedene Werte stehen, wobei einige Werte mehrfach vorkommen. Denken Sie beispielsweise an eine Arbeitszeittabelle, in der Sie Fehlzeiten erfassen. In dieser Tabelle soll nun ermittelt werden, wie oft einzelne, doppelte, dreifache usw. Einträge vorkommen. Es sollen also alle Solisten, Paare, Dreier, Vierer etc. in der Tabelle gezählt werden.

Für das Zählen der Werte, die in Ihrer Tabelle nur einmal vorkommen, verwenden Sie die folgende Formel:

=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A25;$A$1:$A25)=1)/1)

Wenn Sie alle doppelt vorkommenden Werte zählen wollen, passen Sie die Formel so an, dass Sie hinten zweimal die 2 statt der 1 einsetzen. Die Formel sieht dann folgendermaßen aus:

=SUMMENPRODUKT((ZÄHLENWENN($A$1:$A25;$A$1:$A25)=2)/2)

Nach diesem Schema können Sie dann in Ihrer Tabelle alle mehrfach vorkommenden Werte zählen. Setzen Sie dazu hinten in der Formel die passende Anzahl des Auftretens der jeweiligen Werte ein. Die folgende Abbildung zeigt die Formel für das Zählen doppelt vorkommender Werte an einem Beispiel:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"