Excel-Fehlermeldung in einer SVERWEIS-Abfrage abfangen

24. Dezember 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So verhindern Sie Fehler beim Einsatz von SVERWEIS

Verwenden Sie Tabellen mit SVERWEIS-Funktionen? Immer dann, wenn das Suchkriterium nicht gefunden wird, erscheint der Fehlerwert #NV. Sie können diese Fehlermeldung aber unterbinden.

Grundsätzlich ist dieses Verhalten der Funktion SVERWEIS normal. Der Fehlercode #NV besagt, dass das Suchkriterium nicht gefunden wurde.

Sie können die Ausgabe des Fehlercodes #NV verhindern, indem Sie die SVERWEIS-Funktion mit einer ISTFEHLER-Funktion verknüpft in einer WENN-Funktion verwenden. Das ist nicht so kompliziert, wie es sich anhört, wie das folgende Beispiel zeigt. Aus der Formel

=SVERWEIS(C1;A1:B10;2)

wird nach dem obigen Muster die folgende Formel:

=WENN(ISTFEHLER(SVERWEIS(C1;A1:B10;2));"";SVERWEIS(C1;A1:B10;2))

Mit dieser Formel wird eine leere Zelle ausgegeben, wenn das Suchkriterium nicht gefunden wird.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"