Ganzzahlige Werte ganz einfach summieren

20. November 2016
Martin Althaus Von Martin Althaus, Excel, Office ...

Bei der Summierung von Analyseergebnissen oder Produktionsergebnissen sind oft bestimmte Toleranzen zu berücksichtigen. Dann sollen z. B. nur die ganzzahligen Anteile in eine Summe einfließen. Über eine spezielle Matrixformel summieren Sie nur ganzzahligen Anteile der Werte des übergebenen Bereichs.

Verwenden Sie die folgende Formel: 

=SUMME(KÜRZEN(SumBer))

Sie übergeben der Matrixformel mit SumBer nur ein Argument. Mit SumBer definieren Sie, in welchem Bereich die Formel die Summe der ganzzahligen Anteile bilden soll.

Denken Sie daran, die Formel nach der Eingabe über die Tastenkombination Strg+Umschalt+Eingabe abzuschließen, da es sich um eine Matrixformel handelt. 

Die Formel summiert von jeder Zelle des übergebenen Bereichs nur die links vom Komma stehenden Dezimalstellen. Alle Nachkommastellen werden ignoriert.

In der Tabelle aus der Abbildung liefert die folgende Matrixformel in Zelle B16 das Ergebnis 43:

=SUMME(KÜRZEN(B5:B14))

Der Wert 43 ist die Summe der ganzzahligen Anteile der Werte des Bereichs B5:B14. Die Formel rundet jede positive Zahl auf die nächstkleinere ganze Zahl ab. Negative Zahlen werden hingegen auf die nächstgrößere ganze Zahl aufgerundet.

Wenn Sie die positiven und negativen Zahlen immer auf die nächstkleinere ganze Zahl abrunden möchten, dann setzen Sie in der Formel anstelle von KÜRZEN die Tabellenfunktion GANZZAHL ein.

Die Funktion KÜRZEN schneidet beim übergebenen Wert die Nachkommastellen ab. Die Matrixformel führt dies bei jeder Zelle des übergebenen Bereichs durch und übergibt die Ergebnisse an die SUMME-Funktion. Die SUMME-Funktion bildet aus allen übergebenen Werten die Summe.

Nachkommaanteile perfekt summieren

Wenn Sie nicht an den ganzzahligen Anteilen interessiert sind, sondern im Gegenteil nur die Nachkommastellen eines Bereichs addieren möchten, dann benötigen Sie eine andere Matrixformel, die folgenden Aufbau besitzt:

=SUMME(REST(SumBer;1))

Auch dieser Matrixformel übergeben Sie mit SumBer nur ein Argument. SumBer legt den Bereich fest, in dem die Formel die Summe der dezimalen Anteile, also der Nachkommastellen, bilden soll. Auch diese Matrixformel bestätigen Sie nach der Eingabe über die Tastenkombination Strg+Umschalt+Eingabe.

Die Formel summiert von jeder Zelle des übergebenen Bereichs nur die rechts vom Komma stehenden Nachkommastellen. Alle Vorkommastellen werden ignoriert.

In der Tabelle aus der Abbildung liefert die folgende Formel aus Zelle B17 das Ergebnis „3,3“: 

=SUMME(REST(B5:B14;1))

Das Ergebnis „3,3“ ist die Summe aller Nachkommastellen des an die Formel übergebenen Bereichs B5:B14. Wenn Sie die Summe der Dezimalstellen vor dem Komma aus Zelle B16 zu diesem Wert addieren, erhalten Sie „46,3“. Das ist die Summe aller Werte des Bereichs B5:B14.

Mit der REST-Funktion teilen Sie jeden Wert des übergebenen Bereichs durch 1. REST liefert jeweils den Rest dieser Division als Ergebnis. Bei einer Division durch 1 entspricht der Rest immer dem Nachkommaanteil. Die SUMME-Funktion summiert alle gelieferten Nachkommaanteile.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"