Kommentare in Formeln verstecken

11. Juni 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie versteckte Kommentare verwenden

In komplexen Kalkulationen kann es sehr hilfreich sein, Formeln zum besseren Verständnis mit Anmerkungen zu versehen. In den meisten Fällen wird man das mit Kommentaren realisieren.

Diese haben jedoch den Nachteil, dass Sie keine Möglichkeit haben, sie vor neugierigen Blicken zu verbergen, damit nur befugte Personen sie sehen können.

In solchen Fällen integrieren Sie die Kommentare einfach in die Formeln. Wenn Sie diese ausblenden und die Tabelle mit einem Schutz versehen, haben nur Befugte Zugriff darauf. Dazu gehen Sie folgendermaßen vor:

Für das Hinzufügen eines Kommentars zu einer Formel verwenden Sie die Funktion N. Diese ist eigentlich nur aus Kompatibilitätsgründen zu anderen Programmen nötig, hat aber den schönen Nebeneffekt, dass sie bei Text immer den Wert 0 liefert.

Wenn Sie Ihren Kommentar also als Argument der Funktion N zu Ihrer eigentlichen Formel hinzuaddieren, verändert sich am Ergebnis nichts. Sichtbar ist der Kommentar dann in der Bearbeitungszeile.

Die folgende Formel addiert die Zellen A1 bis A15 und enthält den Text "Kommentar":

=SUMME(A1:A15)+N("Kommentar")

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

Achtung: Wenn eine Formel als Ergebnis keine Zahl, sondern einen Text liefert, funktioniert ein Kommentar mit der Funktion N nicht. Dann können Sie eine der Textfunktionen – zum Beispiel RECHTS – verwenden.

Die folgende Formel liefert als Ergebnis den Text "OK" oder eine leere Zelle und ist mit dem Text "Kommentar" versehen:

=WENN(D1>500;"OK";"")&RECHTS("Kommentar";0)

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

In allen Zellen, die einen Kommentar in der Formel enthalten, müssen Sie nun die Formel ausblenden. Dazu rufen Sie im Menü "Format" den Befehl "Zellen" auf. In der erscheinenden Dialogbox aktivieren Sie das Register "Schutz". Klicken Sie anschließend die Optionenen "Gesperrt" und "Ausgeblendet" an. Das bestätigen Sie mit "OK".

Wenn Sie das Blatt nun mit einem Schutz versehen, sind die Formeln nicht mehr sichtbar. Rufen Sie dazu im Menü "Extras" den Befehl "Schutz" und im Untermenü den Befehl "Blatt schützen" auf.

In der erscheinenden Dialogbox wählen Sie die gewünschten Optionen und bestätigen das mit "OK".

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"