Nur positive Berechnungsergebnisse zulassen

25. Dezember 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

So beschränken Sie Ergebnisse auf Zahlen größer als null

In einer Tabelle werden im Bereich A7:A52 Werte eingetragen. Diese werden addiert. Vom Ergebnis ist anschließend ein vorgegebener Wert abzuziehen. In der Ergebniszelle soll allerdings nur dann das Ergebnis angezeigt werden, wenn es positiv ist. Bei negativem Ergebnis soll der Wert null in der Zelle erscheinen.

Angenommen, der zu subtrahierende Wert steht in Zelle B4. Tragen Sie dann die folgende Formel in die Zelle ein, in der das positive Ergebnis oder die Null ausgegeben werden soll – im Beispiel ist das die Zelle B3:

=WENN((SUMME(A7:A52)-B4)>0;SUMME(A7:A52)-B4;0)

Diese Formel fragt ab, ob die Subtraktion des Werts in B4 von der Summe A7:A52 einen Wert liefert, der größer ist als null. Wenn ja, wird das Berechnungsergebnis geliefert, anderenfalls der Wert null. Die folgende Abbildung zeigt den Einsatz der Formel in einer Beispieltabelle:

Statt der vorgestellten Formel können Sie auch ein benutzerdefiniertes Zahlenformat verwenden. Beachten Sie aber unbedingt, dass der Weg über die Formatierung nur funktioniert, wenn Sie mit dem ermittelten Ergebnis keine weiteren Berechnungen durchführen wollen.

Bei negativen Zahlen gaukelt das Zahlenformat Ihnen durch die Anzeige eine Null vor. Intern steht in der Zelle weiterhin ein negativer Wert, der bei Berechnungen verwendet würde.

Für die Zuweisung des benutzerdefinierten Zahlenformats rufen Sie im Menü "Format" den Befehl "Zellen" auf.

In der erscheinenden Dialogbox aktivieren Sie das Register "Zahlen". Dort aktivieren Sie auf der linken Seite die Kategorie "Benutzerdefiniert". In das Eingabefeld "Typ" tragen Sie die folgenden Formatierungsanweisungen ein:

###0;"0"

Die folgende Abbildung zeigt die Definition des Zahlenformats in der Dialogbox:

Bestätigen Sie dieses Zahlenformat mit "OK". In den damit formatierten Zellen werden dann nur noch positive Werte oder die Null bei negativen Zellinhalten angezeigt.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"