So machen Sie Summen von Anfangsbuchstaben abhängig

09. September 2013
Martin Althaus Von Martin Althaus, Excel, Office ...

Artikelcodes, Bestellnummern, Personalnummern oder andere Daten bestehen häufig aus einer Kom­ bination von Zahlen und Buchstaben. Wussten Sie, dass Sie diese Buchstaben in Ihren Berechnungen berücksichtigen können? 

Über die SUMMEWENN-Funktion bilden Sie in Excel ganz komfortabel und bequem bedingte Summen. Wenn Sie dabei aber nicht mit einem bestimmten Inhalt, sondern nur mit ein paar Anfangsbuchstaben vergleichen möchten, müssen Sie die SUMMEWENN-Funktion modifiziert einsetzen:

=SUMMEWENN(Bereich;Anfangsbuchstaben &ʺ*ʺ;SummeBereich)

Sie übergeben der Formel drei Argumente: Mit Bereich übergeben Sie den Bereich, in dem Sie nach einem oder mehreren Anfangsbuchstaben suchen möchten. Das Argument Anfangsbuchstaben legt die Anfangsbuchstaben fest, nach denen Sie in Bereich suchen möchten. SummeBereich ist der Bereich, in dem Sie die Summe bilden möchten.

Als Ergebnis summiert die Formel alle Zellen von SummeBereich, deren entsprechende Zellen in Bereich mit den Anfangsbuchstaben beginnen.

In der abgebildeten Arbeitsmappe liefert die folgende Formel in Zelle E4 den Wert 46.000:

=SUMMEWENN($A$4:$A$12;D4&ʺ*ʺ;$B$4:$B$12) 

Bei diesen 46.000 handelt es sich um die Summe aller Zellen im Bereich B4:B12, die im Bereich A4:A12 mit „Bremen“ aus Zelle D4 beginnen.

Das Sternchen in der Formel sorgt für die gewünschte Suche. Das Sternchen als Suchbegriff führt dazu, dass Excel, von dieser Position ausgehend, die nachfolgenden Zeichen nicht mehr beachtet. Dabei spielt es keine Rolle, um wie viele Zeichen es sich dabei handelt.

Anstelle des Sternchens können Sie auch ein Fragezeichen verwenden. Das Fragezeichen steht als Platzhalter für ein einzelnes Zeichen in einem Suchausdruck. Der Suchausdruck „Köln *“ findet daher sowohl „Köln 1“ als auch „Köln 25“ und „Köln 12“, der Suchausdruck „Köln ?“ aber nur „Köln 1“.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"