Summe trotz Fehlerwerten bilden

25. Oktober 2017
Martin Althaus Von Martin Althaus, Excel, Office ...

Wenn Sie zusätzliche Daten in bestehenden Arbeitsmappen erfassen, können manche Formeln Fehlerwerte liefern, wenn sie kein Ergebnis ermitteln können oder falsche Argumente übergeben bekommen. Solche Fehlerwerte können in Ihren Tabellen und Listen zu Problemen führen, weil alle darauf aufbauenden Formeln ebenfalls Fehlerwerte liefern.

Setzen Sie deshalb Formeln ein, die trotz Fehlerwerten die gesuchten Ergebnisse liefern. Über die folgende Matrixformel ermitteln Sie die Summe eines Bereichs unabhängig von darin enthaltenen Fehlerwerten:

=SUMME(WENN(ISTFEHLER(Bereich);0;Bereich))

Sie übergeben der Formel zweimal mit dem Argument Bereich den Zellbezug, in dem Sie die Summe bilden möchten. Da es sich bei der Formel um eine Matrixformel handelt, müssen Sie sie über die Tastenkombination Strg+Umschalt+Eingabe bestätigen.

Als Ergebnis liefert die Formel die Summe aller Zahlen des übergebenen Bereichs. Jeder Fehlerwert fließt mit 0 in die Berechnung ein. Falls die Fehlerwerte mit einem anderen Wert als 0 in die Berechnung einfließen sollen, ersetzen Sie den Nullwert in der Formel durch die entsprechende Zahl.

In der abgebildeten Arbeitsmappe (1) liefert die folgende Formel in Zelle B10 als Ergebnis den Wert 1.025:

=SUMME(WENN(ISTFEHLER(B3:B8);0;B3:B8))

Die Zahl 1.025 ist die Summe des Bereichs B3:B8. Der in B3 enthaltene Fehlerwert #NV beeinträchtigt die Formel nicht. Anstelle der SUMME-Funktion können Sie in der Formel natürlich auch eine andere Statistikfunktion einsetzen.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"