Wenn Excel scheinbar falsch rechnet

03. Oktober 2013
Martin Althaus Von Martin Althaus, Excel, Office ...

Bei scheinbaren Rechenfehlern handelt es sich nicht um Rechenfehler, sondern um ein Problem bei der Anzeige von Ergebnissen. 

Excel rechnet standardmäßig immer mit bis zu 15 Nachkommastellen. Je nachdem, wie viele dieser Nachkommastellen Sie über das Zahlenformat anzeigen, kann es zu scheinbaren Rechenfehlern kommen. Wenn Sie die angezeigten Zahlen addieren, erhalten Sie ein anderes Ergebnis als über eine Formel.

Das können Sie ändern, indem Sie Excel so einstellen, dass es so rechnen soll, wie auch angezeigt wird:

  1. Rufen Sie den Menübefehl Extras – Optionen auf.
  2. Wechseln Sie ins Register Berechnung.
  3. Schalten Sie die Option Genauigkeit wie angezeigt ein.

Ab Excel 2007 schalten Sie diese Methode über das Register Erweitert der Excel-Optionen ein. Sie finden dort die Option Genauigkeit wie angezeigt festlegen.

Achtung: Durch die Aktivierung dieser Option werden alle Dezimalstellen wie angezeigt in die Zellen übernommen, möglicherweise genauere, aber nicht sichtbare Nachkommastellen gehen dadurch verloren. Eine Alternative zu dieser Option ist das Summieren über eine Matrixformel, mit der Sie alle Zahlen auf eine bestimmte Dezimalstelle runden:

=SUMME(RUNDEN(Bereich;Dezimastelle))

Mit Bereich übergeben Sie den Bereich, dessen Zahlen Sie summieren möchten. Über das Argument Dezimalstelle definieren Sie, auf welche Stelle gerundet werden soll. Bestätigen Sie die Formel über die Tastenkombination STRG+UMSCHALT+EINGABE, da es sich um eine Matrixformel handelt.

Die abgebildete Arbeitsmappe verwendet in Zelle B13 die folgende Formel:

=SUMME(RUNDEN(B4:B10;1))

Sie erkennen den Unterschied zur ungerundeten Summe in Zelle B12.

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"