Wie Sie das Auftreten von Ziffern in einem Excel-Zellbereich zählen

13. März 2012
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie oft kommt eine bestimmte Ziffer in einem Excel-Bereich vor

So zählen Sie die Anzahl einer bestimmten Ziffer in einem Zellbereich von Excel

So zählen Sie die Anzahl einer bestimmten Ziffer in einem Zellbereich von Excel

Sie möchten wissen, wie oft eine bestimmte Ziffer in einem Zellbereich auftritt? Das kann zur Auswertung von Kundendaten, Artikelnummern oder anderen Informationen hilfreich sein.

Zählen Sie, wie oft eine bestimmte Ziffer in einem Zellbereich auftritt. Diese Aufgabenstellung lösen Sie über eine Matrixformel. Wenn Sie beispielsweise zählen möchten, wie oft die Ziffer, die sich in Zelle B2 befindet, im Zellbereich A2:A11 auftritt, verwenden Sie die folgende Matrixformel:

=SUMME((LÄNGE($A$2:$A$11)-LÄNGE(WECHSELN($A$2:$A$11;B2;""))))

Bestätigen Sie die Matrixformel nach der Eingabe über die Tastenkombination

STRG UMSCHALT EINGABE. Mit UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Auch nach einer Änderung der Formel müssen Sie die Formel über diese Tastenkombination bestätigen.

Die Formel zählt das übergebene Zeichen, auch wenn diese sich innerhalb eines Wortes befindet. Groß- und Kleinschreibung wird dabei beachtet. Die folgende Abbildung zeigt den Einsatz der Formel in der Praxis

So zählen Sie die Anzahl einer bestimmten Ziffer in einem Zellbereich von Excel

Das Ergebnis von 3 in Zelle C2 zeigt, dass die Ziffer 1 in allen Zahlen im Bereich A2:A11 insgesamt drei Mal auftritt.

Durch den Einsatz der Dollarzeichen in der Formel setzen Sie den Bereich als absoluten Bezug ein. Das ermöglicht es Ihnen, die Formel in andere Zellen zu kopieren und dennoch den gleichen Zellbereich zu überprüfen.

Verwandte Themen:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"