ZÄHLENWENN mit zwei Bedingungen verwenden

14. August 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So filtern Sie Listen nach zwei Kriterien

Mit der Funktion ZÄHLENWENN können Sie sehr komfortabel die Elemente einer Liste zählen, die einem vorgegebenen Kriterium entsprechen. Problematisch wird es, wenn Sie versuchen, dabei zwei Bedingungen mit der Funktion UND zu verknüpfen.

Denken Sie beispielsweise an eine Liste, in der Sie alle Zellen zählen wollen, deren Inhalt größer als 20 und kleiner als 80 ist.

Bei der Verknüpfung dieser beiden Bedingungen werden Sie bemerken, dass die Berechnung grundsätzlich das Ergebnis null liefert. Das liegt daran, dass die Funktion ZÄHLENWENN nur auf die Verwendung mit einer Bedingung ausgerichtet ist.

Mit einem kleinen Trick können Sie die Funktion jedoch trotzdem für die beschriebene Aufgabe nutzen.

Für die Lösung der Aufgabe verwenden Sie zweimal die Funktion ZÄHLENWENN. Zuerst werden alle Werte gezählt, die größer als 20 sind. Von diesem Ergebnis wird dann die Anzahl der Werte subtrahiert, die größer oder gleich 80 sind.

Wenn die Liste mit den Werten im Bereich A1:A20 steht, sieht die Formel in der Ergebniszelle – im folgenden Beispiel die Zelle B1 – folgendermaßen aus:

=ZÄHLENWENN(A1:A20;">20")-ZÄHLENWENN(A1:A20;"">=80)

Die folgende Abbildung zeigt den Einsatz der ergänzten Formel in einer Tabelle mit der Ergebniszelle B1:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"