So runden Sie mit Calc

07. April 2015
Achim Wagenknecht Von Achim Wagenknecht, Freeware & Open Source, News & Trends, Linux, OpenOffice, Picasa, GIMP, Multimedia ...

Die Tabellenkalkulation von LibreOffice kann vollautomatisch runden. Sie können aber auch beeinflussen, wie das Programm auf- oder abrundet.

Windows+Linux / Deutsch / Open Source. Sie haben wahrscheinlich in der Grundschule gelernt, wie man auf- und abrundet: Wenn eine Zahl zu lang ist, wird sie gekürzt. Dabei betrachtet man die letzte Stelle, die man beibehalten will, und die danach. Ist die Stelle danach kleiner als 5, rundet man ab, sonst auf. Beim Abrunden bleibt die Stelle, die man behalten will, gleich, beim Aufrunden zählt man eins weiter.

LibreOffice Calc erledigt das je nach Zahlenformat automatisch. Rechnen Sie 1/8 im Standardformat, so ergibt das 0,125. In Euro erhalten Sie stattdessen 0,13 - Calc rundet automatisch auf volle Cent. Intern behält das Programm jedoch die genaue Zahl bei. Das merken Sie, wenn Sie die 13 Cent wieder mit 8 multiplizieren: Das Ergebnis ist genau ein Euro. Geben Sie jedoch 13 Cent direkt ein und multiplizieren mit 8, so ist das Ergebnis 1,04 Euro.

Je nach Anwendung kann die höhere Genauigkeit aber unerwünscht sein. Findet ein Zahlungsvorgang statt, so kann dieser ja nur mit vollen Cent durchgeführt werden. Es ist also nicht sinnvoll, hier mehr als zwei Nachkommastellen mitzuführen.

Für solche und andere Fälle gibt es in Calc die Funktion RUNDEN(). Geben Sie der Funktion eine Zahl mit, so wird diese auf eine Ganzzahl gerundet. Möchten Sie auf eine bestimmte Zahl von Stellen runden, so geben Sie die Anzahl der Stellen als zusätzlichen Parameter ein. Für das kaufmännische Runden auf ganze Cent sieht das so aus:
=RUNDEN(A2;2)

Möchten Sie auf Hunderter, Tausender oder dergleichen runden, so geben Sie eine negative Zahl als Anzahl gewünschter Stellen ein. Um auf Hunderter zu runden, brauchen Sie zum Beispiel diese Formel:
=RUNDEN(A2;-2)

Mehr zum Thema

So nutzen Sie endlich alle Office-Möglichkeiten!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Windows-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"