Multiplizieren und Addieren von Excel-Daten in einem Arbeitsgang

Multiplizieren und Addieren von Excel-Daten in einem Arbeitsgang

Wie Sie Summen und Produkte in einer Formel zusammenfassen

Sie möchten Werte miteinander multiplizieren und anschließend die Summe aus den Produkten bilden? Machen Sie es sich einfach und erledigen Sie die Aufgabe in einem Arbeitsgang.

Excel besitzt eine sehr nützliche Funktion, mit der Sie die Summe aus multiplizierten Werten blitzschnell berechnen können. Indem Sie innerhalb dieser Funktion SUMMENPRODUKT mehrere logische Vergleiche einbinden, können Sie Summen unter Einbeziehung einer Anzahl blitzschnell berechnen.

In der Abbildung sehen Sie eine Liste mit Namen. In Zelle B16 möchten Sie die Summe der Multiplikationen der beiden Spalten "Anzahl" und "Preis" ermitteln. Dabei sollen aber nur diejenigen Zeilen berücksichtigt werden, bei denen die Kriterien des Bereichs A13:B14 zutreffen, also die Art "A" und die Farbe "gelb". Dazu setzen Sie in Zelle B16 die folgende Formel ein:

 

=SUMMENPRODUKT((B4:B10=B13)*(C4:C10=B14)*D4:D10*E4:E10)

Als Ergebnis liefert die Formel den Wert 500. Dieser Wert setzt sich aus den beiden Zeilen 6 und 10 zusammen, 1 * 300 plus 1 * 500.

Sie können auf diesem Weg natürlich auch mehr als zwei Abfragekriterien miteinander kombinieren und dabei auch andere Vergleiche als ein Gleichheitszeichen verwenden.