SVWERS Excel Formel

Mit ISTNV beim SVERWEIS eine #NV-Meldung unterdrücken

Mit dieser Schritt-für-Schritt-Anleitung lösen Sie das Problem im Nu

Kommt Ihnen als geübtem Excel-Anwender die folgende Situation bekannt vor? Beim SVERWEIS erhalten Sie bei exakter Suche – wenn in der Suchmatrix der Wert nicht vorhanden ist – als Ergebnis #NV für „no value“ oder „nicht vorhanden“.

Videoanleitung - Excel: SVERWEIS - #NV Meldung unterdrücken mit ISTNV

So bauen Sie eine WENN-Funktion um eine IST-Funktion

Dieses Schönheitsproblem lösen Sie, indem Sie eine WENN-Funktion um eine IST-Funktion, in diesem Fall ISTFEHLER oder ISTNV, legen. 

Die Formel bauen Sie wie folgt auf: 

  1. Markieren Sie die Zelle „Typenkennzeichen.“ 

  2. Geben Sie in die Bearbeitungszeile =WENN( ein. 

  3. Prüfen Sie im nächsten Schritt, ob das Ergebnis des SVERWEIS den Fehlerwert #NV liefert. Tragen Sie hierzu direkt hinter der Klammer folgende Formel ein: 

    ISTNV(SVERWEIS(B11;A5:B9;2;Falsch;“Nicht spezifiziert!“) 

  4. Geben Sie nun ein Semikolon ein. Des Weitere integrieren Sie in der Folge für den Dann-Wert der WENN-Funktion zwei Anführungszeichen direkt hintereinander. Durch dieses Vorgehen wird der Fehlerwert „#NV“ durch eine leere Zelleingabe ersetzt, sobald der Wert in der Suchmatrix nicht vorhanden ist.

  5. Geben Sie im letzten Schritt ein weiteres Semikolon ein und tragen Sie für den Sonst-Wert der WENN-Funktion erneut den SVERWEIS ein. Dieser extrahiert automatisch aus der Matrix die gesuchte Bezeichnung.

Ihre komplette Formel müsste nun wie folgt aussehen: 

=WENN(ISTNV(SVERWEIS(B11;A5:B9;2;FALSCH));"Nicht spezifiziert";SVERWEIS(B11;A5:B9;2;FALSCH))

Alternativmöglichkeit: Nutzen Sie die Funktion WENNNV

Seit der Einführung von Excel 2013 können Sie alternativ ebenfalls die Funktion WENNNV nutzen, mit der die beschriebene „NV-Fehlermeldung“ effektiver und eleganter gelöst wird. Die Funktion WENNNV benutzen Sie wie folgt: 

  1. Markieren Sie Zelle E5. 

  2. Geben Sie in die Bearbeitungszeile =WENNNV( ein. 

  3. Tragen Sie hinter der Klammer den SVERWEIS wie folgt ein: SVERWEIS(B11;A5:B9;2;FALSCH)

  4. Geben Sie ein Semikolon ein und tragen Sie als zweites Argument für die Funktion WENNNV den Wert ein, der ausgegeben werden soll, wenn der SVERWEIS den Rückgabewert #NV liefert. Geben Sie wie bei der Wenn-Funktion hierfür zwei Anführungszeichen direkt hintereinander ein.

Ihre komplette Formel müsste nun wie folgt aussehen: 

=WENNNV(SVerweis(B11;A5:B9;2;FALSCH);“Nicht spezifiziert!“) 

Zusammenfassung und Fazit: Mit den Funktionen WENN oder WENNNV unterdrücken Sie bei einem SVERWEIS NV-Meldungen effizient 

Es ist unschön, wenn Sie bei einem SVERWEIS bei exakter Suche als Ergebnis den Fehler #NV für „no value“ oder „nicht vorhanden“ erhalten. Sie können die Fehlermeldung abstellen, indem Sie  eine WENN-Funktion um eine IST-Funktion legen. Nutzer ab der Excel-Version 2013 können darüber hinaus mit der Funktion WENNNV arbeiten. 

FAQ

Welche Funktion hat der SVERWEIS in Microsoft Excel?

Mit der Funktion SVERWEIS, deren Abkürzung für Suchverweis steht, soll ein Wert aus einer vorgegebenen Tabelle ermittelt werden. Die Funktion SVERWEIS wird häufig von Excel-Anwendern genutzt, wenn Werte oder Informationen aus umfangreichen Excel-Tabellen extrahiert werden müssen. Suchen Sie beispielsweise den Preis eines Produkts, von dem Sie ausschließlich die Teilenummer kennen, können Sie die Excel-Funktion SVERWEIS zur effektiveren und schnelleren Suche nutzen.

Der SVERWEIS in Microsoft Excel kann vor allem in den folgenden Arbeits- und Aufgabenbereichen angewendet werden:  

  • Prüfung, ob ein bestimmter Wert einer Tabelle ebenfalls in der anderen enthalten ist.  

  • Vergleich zwischen zwei Tabellen.  

  • Erweiterung des Inhalts einer Tabelle mit den Daten einer zweiten Tabelle.

Die Funktion WENNNV kann ab der Version von Microsoft Excel 2013 verwendet werden, um einen angegebenen Wert zurückzuspielen, wenn die Formel den Fehlerwert #N/V liefert. Dies bedeutet für die Praxis, das statt des Fehlerwertes #N/V ein individueller Text, zum Beispiel: „Artikel nicht vorhanden“ angezeigt werden kann. Bei einer korrekten Berechnung wird das Ergebnis der Formel ausgegeben.