Alle Zeichen aus einer Zelle auflisten

30. November 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

So stellen Sie alle Zeichen ohne Wiederholungszeichen dar

In einer Tabelle sollen von einem in Zelle A1 stehenden Text alle vorkommenden Zeichen in einzelnen Zellen aufgelistet werden. Duplikate sollen dabei nicht ausgegeben werden. Eine integrierte Funktion steht in Excel dafür nicht zur Verfügung. Tragen Sie daher in die Zelle B1 die folgende Formel ein:

=TEIL(A$1;KKLEINSTE(WENN(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99);ZEILE($1:$99));ZEILEN(A$2:A2));1)

Die Eingabe der Formel bestätigen Sie mit der Tastenkombination STRG UMSCHALT EINGABE, da es sich um eine Matrixformel handelt. Mit der Taste EINGABE ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Anschließend kopieren Sie die Formel in der Spalte B in die darunter liegenden Zellen.

Sobald alle Zeichen in der Spalte B dargestellt sind, liefert die Formel in den restlichen Zellen  einen Fehlerwert. Diesen  Fehlerwert können Sie abfangen, indem Sie die folgende Formel verwenden, die Sie ebenfalls mit STRG UMSCHALT EINGABE bestätigen:

=WENN(ZEILEN(A$2:A2)>SUMME(N(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99)));““;TEIL(A$1;KKLEINSTE(WENN(FINDEN(TEIL(A$1;ZEILE($1:$99);1);$A$1)=ZEILE($1:$99);ZEILE($1:$99));ZEILEN(A$2:A2));1))

Die folgende Abbildung zeigt den Einsatz dieser Formel in einer Beispieltabelle:

Auch Änderungen der Formel müssen Sie immer mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen. Die Formel funktioniert auch bei Zahlen oder Kombinationen aus Formeln und Zahlen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"