Anzahl gerader Zahlen innerhalb eines Bereichs zählen

06. August 2013
Martin Althaus Von Martin Althaus, Excel, Office ...

Über die folgende Spezialformel zählen Sie die Anzahl der geraden Zahlen, die innerhalb eines bestimmten Wertebereichs liegen: 

=SUMMENPRODUKT((Bereich>=Untergrenze) *(Bereich<=Obergrenze)*(REST(Bereich;2)=0))

Sie übergeben der Formel drei Argumente: Mit Bereich legen Sie den Zellbereich fest, in dem Sie die geraden Zahlen zählen möchten. Über die Argumente Obergrenze und Untergrenze definieren Sie den Wertebereich. Nur die Zahlen innerhalb dieses Bereichs werden gezählt. Als Ergebnis liefert die Formel die Anzahl der geraden Zahlen im übergebenen Bereich, die größer oder gleich der Untergrenze und kleiner oder gleich der Obergrenze sind.

In der abgebildeten Arbeitsmappe besitzt die Formel in Zelle E5 den folgenden Aufbau:

=SUMMENPRODUKT((A3:B8>=E4)*(A3:B8<=E3)*(REST(A3:B8;2)=0)) 

Um die geraden Zellen des gewünschten Wertebereichs zu zählen, setzt die Formel die folgende Methode ein:

  • In die Formel sind drei Vergleiche eingebunden.
  • Zum einen wird der übergebene Bereich mit der Obergrenze und der Untergrenze verglichen.
  • Der dritte Vergleich prüft, ob der Rest der Division durch 2 den Wert 0 ergibt. Nur dann handelt es sich um eine gerade Zahl.
  • Jeder Vergleich liefert bei erfolgreichem Ausgang als Ergebnis den Wert 1.
  • Ist der Vergleich negativ, wird als Ergebnis der Wert 0 geliefert.
  • Indem die drei Vergleiche miteinander multipliziert werden, ergibt das Produkt nur dann den Wert 1, wenn alle Vergleiche positiv ausfallen.
  • Diese Einsen werden über SUMMENPRODUKT addiert.

Falls Sie anstelle der geraden die ungeraden Zahlen zählen möchten, dann ersetzen Sie das =0 durch ein =1.

Wenn die beiden Grenzen nicht mitgezählt werden sollen, dann entfernen Sie die Gleichheitszeichen aus den beiden Vergleichen >= und <=.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"