Anzahl unterschiedlicher Excel-Zellinhalte mit Bedingung zählen

09. Juni 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Zählen Sie die Anzahl der Datensätze, zu denen in einer bestimmtem Spalte ein passendes Kriterium in Ihrer Excel-Liste vorkommt

Zählen Sie unterschiedliche Zellinhalte per Excel-Formel

Zählen Sie unterschiedliche Zellinhalte per Excel-Formel

Stellen Sie sich eine Liste vor, in der Sie das Auftreten unterschiedlicher Zellinhalte zählen wollen. Dabei sollen aber nur die Zellen berücksichtigt werden, bei denen in der Nachbarzelle ein bestimmtes Zeichen steht. Leerzellen sollen bei der Zählung nicht berücksichtigt werden.

Hier ein konkretes Beispiel: In A1:A50 sollen alle unterschiedlichen Einträge gezählt werden. Es sollen aber nur die Einträge berücksichtigt werden, bei denen in Spalte B ein "x" steht.

Für die Lösung dieser Aufgabe tragen Sie die folgende Formel in die Zelle ein, in der das Ergebnis erscheinen soll:

=SUMME(N(WENN(B1:B50="x";VERGLEICH(WENN(B1:B50="x";A1:A50);WENN(B1:B50="x";A1:A50);)=ZEILE(1:50))))

Bei dieser Formel handelt es sich um eine Matrix-Formel. Deshalb müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen. Mit der Taste UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Excel stellt die Formel innerhalb von geschweiften Klammern dar, wenn sie korrekt als Matrixformel eingegeben worden ist.

Die folgende Abbildung zeigt die Formel in der Befehlszeile einer Beispieltabelle:

Zählen Sie unterschiedliche Zellinhalte per Excel-Formel

Diese Formel können Sie bei Bedarf um weitere Bedingungen ergänzen. Wenn beispielsweise auch noch zusätzlich Spalte C auf den enthaltenen Text "y" geprüft werden soll, sieht die Matrixformel (STRG UMSCHALT EINGABE) folgendermaßen aus:

=SUMME(N(WENN((B1:B50="x")*(C1:C50="y");VERGLEICH(WENN((B1:B50="x")*(C1:C50="y");A1:A50);WENN((B1:B50="x")*(C1:C50="y");A1:A50);)=ZEILE(1:50))))

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"