Anzahl unterschiedlicher Werte in einer Excel-Liste ermitteln

10. Juni 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So finden Sie heraus, wie Ihre Daten in Excel strukturiert sind

Stellen Sie sich eine Liste in einem Tabellenblatt vor, in der Sie Messwerte erfassen. Darin möchten Sie ermitteln, wie viele unterschiedliche Werte die Liste enthält. Die Liste könnte beispielsweise folgendermaßen aussehen:

rtemagicc_20080610-1bmp.jpg

Diese Aufgabenstellung lösen Sie mit einer Formel, in der die Funktionen SUMME, WENN und HÄUFIGKEIT miteinander kombiniert werden.

Wenn der zu untersuchende Bereich wie im obigen Beispiel die Zellen B2:E22 umfasst, sieht die Formel folgendermaßen aus:

=SUMME(WENN(HÄUFIGKEIT(B2:E22;B2:E22)>0;1))

Damit die Formel funktioniert, müssen Sie sie über die Tastenkombination STRG SHIFT ENTER eingeben (mit SHIFT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch UMSCHALT genannt).

Mit dieser Tastenkombination geben Sie Matrixformeln ein. Anschließend stellt Excel die Formel in geschweiften Klammern dar. Auch nach einer Änderung der Formel müssen Sie immer die Tastenkombination STRG SHIFT ENTER verwenden, um die Formel einzugeben.

Im vorliegenden Beispiel lautet das Ergebnis der Berechnung 10. Die Liste enthält also zehn unterschiedliche Werte. Die folgende Abbildung zeigt die Formel in der Tabelle:

rtemagicc_20080610-2bmp.jpg

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"