Benzinverbrauch und Kilometerstand per Excel erfassen und auswerten

19. Oktober 2012
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie die Differenz zwischen erster und letzter Zelle gezielt berechnen und damit den KFZ-Benzinverbrauch per Excel berechnen

So berechnet die Tanktabelle den Benzinverbrauch von Fahrzeugen in der Praxis

So berechnet die Tanktabelle den Benzinverbrauch von Fahrzeugen in der Praxis

In einer Tabelle sollen für eine Fahrzeugflotte die Kilometerstände beim Tanken und die Tankmenge erfasst werden. Zu berechnen sind dann die zwischen zwei Tankstopps gefahrenen Kilometer und der Verbrauch. Natürlich funktioniert die Liste auch mit nur einem Fahrzeug.

Die Tabelle ist so aufgebaut, dass es für jeden Tag eine Zeile gibt. Nicht jedes Fahrzeug wird täglich betankt. Differenzen und Verbrauch sind immer nur zwischen zwei Tankstopps zu ermitteln, unabhängig davon, wie viele Tage dazwischenliegen. Die folgende Abbildung zeigt den Aufbau der Beispieltabelle:

Aufbau der Tanktabelle zur Berechnung des Benzinverbrauchs

Für die Berechnung der Kilometerdifferenz in Spalte D muss zuerst überprüft werden, ob in der jeweiligen Zeile ein Kilometerstand eingetragen wurde. Wenn ja, wird vom aktuellen Stand der höchste der darüberliegenden abgezogen, der immer der des letzten Tankstopps ist.

Die Formel für diese Berechnung sieht für die erste Zeile D4 der Beispieltabelle folgendermaßen aus:

=WENN(B4<>"";B4-MAX(B$3:B3);"")

Wichtig in dieser Formel ist der absolute Bezug auf die Zelle B3. Damit wird sichergestellt, dass bei der Ermittlung des Maximums immer der Bereich vom Übertrag bis zur Zelle über der aktiven berücksichtigt wird. Die folgende Abbildung zeigt den Einsatz der Formel in einer Beispieltabelle:

Excel-Formel für die Kilometerdifferenz

Diese Formel kopieren Sie in der Spalte ausreichend weit nach unten. Solange noch keine Kilometerstände eingetragen sind, bleiben die Ergebniszellen leer.

Auch für die Ermittlung des Verbrauchs in Spalte E überprüfen Sie, ob in der entsprechenden Zeile ein Kilometerstand eingetragen wurde. Wenn ja, teilen Sie die gefahrenen Kilometer durch die getankten Liter und multiplizieren das Ergebnis mit 100. Für die erste Zeile der Beispieltabelle setzen Sie das mit der folgenden Formel in Zelle E4 um:

=WENN(B4<>"";C4/D4*100;"")

Die folgende Abbildung zeigt den Einsatz dieser Formel in der Beispieltabelle:

Verwenden Sie diese Formel für den Benzinverbrauch

Auch die Formel für die Verbrauchsberechnung kopieren Sie in der Spalte ausreichend weit nach unten. Damit ist die Tabelle fertig und bereit für die Eingabe von Tankdaten.

Nachdem Sie Daten eingegeben haben, erhalten Sie sofort die dazugehörigen Berechnungen für die zurückgelegten Wegstrecken und den resultierenden Verbrauch. Die folgende Abbildung zeigt die Tanktabelle mit eingetragenen Werten in der Beispieltabelle:

So berechnet die Tanktabelle den Benzinverbrauch von Fahrzeugen in der Praxis

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"