Finden Sie gesuchte Inhalte direkt per Formel

29. August 2017
Martin Althaus Von Martin Althaus, Excel, Office ...

Über den Menübefehl "Bearbeiten - Suchen" können Sie beliebige Inhalte in Ihren Arbeitsmappen suchen und finden und somit prüfen, wo ein bestimmter Inhalt auftritt. Um aber direkt in einer Zelle zu prüfen, ob ein bestimmter Inhalt auftritt, benötigen Sie eine Formel.

Der Nachteil, über das Dialogfenster Suchen nach einem Inhalt zu forschen, besteht darin, dass Sie die Aufgabe immer dann wiederholen müssen, wenn sich Daten in Ihren Tabellen verändern. Beim Suchen mit einer Formel ist das nicht der Fall. Sie reagiert auf die geänderten Inhalte in Ihren Zellen automatisch und findet die Informationen, die Sie suchen. Die folgende Formel prüft, ob ein bestimmter Text in einer Zelle auftritt:

=WENN(ISTZAHL(SUCHEN(Suchtext;Text));
"enthalten";"nicht enthalten")

Sie übergeben der Formel zwei Argumente: Mit Suchtext übergeben Sie den Text, nach dem Sie suchen möchten, oder die Zelle, in der sich dieser Text befindet. Das Argument Text legt die Zelle fest, in der der Suchtext gesucht werden soll.
Falls der Suchtext in Text auftritt, liefert die Formel das Ergebnis "enthalten". Tritt Suchtext in Text nicht auf, liefert die Formel das Ergebnis "nicht enthalten".

In Zelle C4 der abgebildeten Arbeitsmappe liefert die folgende Formel das Ergebnis "enthalten":

=WENN(ISTZAHL(SUCHEN($B$15;A4));
"enthalten";"nicht enthalten")

Der gesuchte Text "Schwelm" aus Zelle B4 ist im Text aus Zelle A4 enthalten. Deshalb liefert die Formel als Ergebnis den Text "enthalten".

Anstelle der beiden Texte "enthalten" und "nicht enthalten" können Sie auch beliebige andere Texte in der Formel verwenden.
Die Formel kann auch nach Zahlen suchen, die innerhalb des Textes enthalten sind.

So überprüft die Formel den Text in Ihren Tabellen

Die Formel zur Prüfung des Textes funktioniert nach folgendem Prinzip:

  • Die SUCHEN-Funktion sucht den Text aus Zelle B4 innerhalb von Zelle A4.
  • Falls der Text vorhanden ist, liefert die SUCHEN-Funktion die Position, an der der gesuchte Text innerhalb des Textes von Zelle A4 beginnt.
  • In diesem Falle liefert die ISTZAHL-Funktion den Wahrheitswert WAHR, da ihr eine Zahl übergeben wurde.
  • Die WENN-Funktion gibt dann den Text "enthalten" aus.
  • Falls der Text aus B4 nicht in A4 vorhanden ist, liefert die SUCHEN-Funktion als Rechenergebnis einen Fehlerwert.
  • Die Funktion ISTZAHL liefert dann den Wahrheitswert FALSCH, weil keine Zahl als Argument übergeben wurde.
  • Die WENN-Funktion gibt danach den Text "nicht vorhanden" aus.
  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"