Jede zweite Spalte in einer Excel-Tabelle addieren

22. Januar 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

So bilden Sie Summen, in denen Spalten ausgelassen werden

Stellen Sie sich eine Tabelle vor, in der Sie in Zeilen Summen bilden wollen, bei denen nur jede zweite Spalte berücksichtigt wird. Denken Sie an eine Liste mit Umsätzen, in der an jedem Tag zwei Spalten zugeordnet werden, eine für den Nettoumsatz und eine für die Mehrwertsteuer.

Für die tägliche Addition der Umsätze benötigen Sie eine Formel, die überprüft, ob sich die Werte in Spalten mit gerader Spaltennummer befinden oder nicht. Daraufhin wird der Wert der Summe hinzugefügt oder eben nicht.

Wenn es sich nur um einige wenige Werte handelt, die Sie addieren müssen, können Sie die Zahlen auch einzeln per Pluszeichen verknüpfen, aber was machen Sie in umfangreichen Tabellen? Gehen Sie folgendermaßen vor:

Wenn in der Tabelle die Umsätze des ersten Tages in Zeile 3 erfasst sind, stehen in Zelle B3 die Nettoumsätze des ersten Tages und in Zelle C3 die Mehrwertsteuer dieses Tages.

Die Nettoumsätze erhalten Sie durch Addition der Werte aus geraden Spalten; die Mehr-wertsteuer steht in den ungeraden. Ob eine Spalte gerade oder ungerade ist, erfahren Sie, wenn Sie die Zeilennummer durch 2 teilen und den ganzzahligen Rest betrachten: Bei gerader Spalte ist der Rest Null.

Für die Summe der Nettoumsätze verwenden Sie die folgende Formel:

=SUMME((REST(SPALTE(B3:M3);2)=0)* B3:M3)

Da es sich um eine Matrixformel handelt, müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen. Mit UMCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Sie wird auch SHIFT genannt. Die folgende Abbildung zeigt, wie die Formel in der Praxis arbeitet:

Für die ungeraden Spalten ersetzen Sie "=0" durch "<>0".

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"