Jede zweite Zeile einer Excel-Liste zu einer Summe addieren

02. April 2012
Martin Althaus Von Martin Althaus, Excel, Office ...

Mit diesen Formeln bilden Sie Summen, die nur jede zweite Zelle berücksichtigen

Stellen Sie sich eine Tabelle vor, in der Sie in Spalten Summen bilden wollen, bei denen nur jede zweite Zeile berücksichtigt wird.

Denken Sie beispielsweise an eine Liste, in der Umsätze erfasst werden. Dabei sind jedem Tag zwei Zeilen zugeordnet, eine für den Nettoumsatz und eine für die Mehrwertsteuer. Am Monatsende sollen die Nettoumsätze addiert werden. Die folgende Abbildung zeigt eine Beispieltabelle:

Stellen Sie sich vor, Sie möchten alle Zahlen im Bereich C2:C61 addieren, aber dabei nur die Zellen mit geraden Zeilennummern berücksichtigen, also C2, C4 usw.

Für die gewünschte Addition benötigen Sie eine Matrixformel. In dieser wird überprüft, ob sich die Werte in Zeilen mit gerader Zeilennummer befinden oder nicht. Abhängig von dieser Überprüfung wird der Wert dann der Gesamtsumme hinzugefügt oder nicht.

Wenn in der Tabelle die Umsätze der ersten Filiale in Spalte C erfasst sind, stehen in der Zelle C2 die Nettoumsätze des ersten Tags und in Zelle C3 die Mehrwertsteuer dieses Tags.

Die Nettoumsätze erhalten Sie also, wenn Sie die Werte aus den geraden Zeilen addieren; die Mehrwertsteuer steht in den ungeraden Zeilen. Ob es sich bei einer Zeile um eine gerade oder eine ungerade handelt, erfahren Sie, wenn Sie die Zeilennummer durch 2 teilen und den ganzzahligen Rest betrachten: Bei einer geraden Zeile ist der Rest null, ansonsten nicht.

In der Beispieltabelle soll die Summe der Nettoumsätze in der Zeile 63 addiert werden. Dazu verwenden Sie die folgende Formel:

=SUMME((REST(ZEILE(C2:C61);2)=0)*C2:C61)

Damit die Formel funktioniert, müssen Sie sie über die Tastenkombination STRG SHIFT ENTER eingeben (mit SHIFT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch UMSCHALT genannt). Dann stellt Excel die Formel in geschweiften Klammern dar.

Auch nach einer Änderung der Formel müssen Sie immer die Tastenkombination STRG SHIFT ENTER verwenden, um die Formel einzugeben.

Die Summe der Mehrwertsteuer in den ungeraden Zeilen erhalten Sie entsprechend mit der folgenden Formel, die Sie ebenfalls mit STRG UMSCHALT EINGABE bestätigen:

=SUMME((REST(ZEILE(C2:C61);2)<>0)*C2:C61)

Die folgende Abbildung zeigt den Einsatz der Matrixformel für die Addition der Mehrwertsteuer in der Beispieltabelle:

So funktioniert die Formel:

Über die ZEILE-Funktion wird die Nummer der Zeile ermittelt. Über REST wird geprüft, welchen Rest diese Zeilennummer bildet, wenn man sie durch 2 teilt. Ist der Rest 0, ist es eine gerade Zeilennummer, ist der Rest größer oder kleiner, handelt es sich um eine ungerade Zeilennummer.

Diese Bedingung wird über eine WENN-Funktion überprüft. Fällt sie positiv aus, wird zu der Summe der entsprechende Zellinhalt addiert, ansonsten wird eine 0 an die Funktion SUMME übergeben. Durch die Matrixformel sorgt das Kommando dafür, dass die Operation für alle Zellen im Bereich A1:A10000 der Reihe nach durchgeführt wird.

Verwandte Themen:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"