Monatstage eines Zeitraums auflisten

10. Februar 2009
Martin Althaus Von Martin Althaus, Excel, Office ...

So erhalten Sie eine Liste mit den kompletten Monatstagen

In einer Tabelle sollen für jeden Monat die in den jeweiligen Monat fallenden Tage aufgelistet werden. Die Tabelle hat den folgenden Aufbau: Das Anfangsdatum steht in Zelle A2, das Enddatum in B2. Beachten Sie, dass das Enddatum nicht vor dem Anfangsdatum liegen darf.

In der ersten Zeile sollen nun mit einer Formel die jeweiligen Monatsnamen ausgegeben werden. Für den ersten Monat tragen Sie die folgende Formel in Zelle C1 ein:

=DATUM(JAHR(A2);MONAT(A2)+1;)

In Zelle D1 tragen Sie die die folgende Formel ein:

=WENN($B2<=C1;"";C1+32-TAG(C1+32))

Beiden Zellen weisen Sie dann das benutzerdefinierte Format: MMM JJ zu.

In der zweiten Zeile sollen die jeweiligen Tage für die Monate in der ersten Zeile ausgerechnet werden. Dazu verwenden Sie die folgende Formel in Zelle C2:

=MIN(C1;$B2)-A2+1

In D2 tragen Sie die folgende Formel ein:

=WENN(D1="";"";MIN(D1;$B2)-C1)

Die Zellen D1 und D2 kopieren Sie anschließend ausreichend weit nach rechts. In der Tabelle werden dann die jeweiligen Monatstage in der gewünschten Form angezeigt, wie die folgende Abbildung zeigt:

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"