Wie Sie die Excel-Funktion SVERWEIS für die Unterscheidung von Großschreibung und Kleinschreibung verwenden

02. Juni 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

Um die Excel-Funktion SVERWEIS mit Großbuchstaben und Kleinbuchstaben gleichermaßen zu nutzen, setzen Sie eine trickreiche Formel ein

Eine Abfrage mit Groß- und Kleinschreibung per Excel-Formel

Eine Abfrage mit Groß- und Kleinschreibung per Excel-Formel

SVERWEIS und andere Excel-Verweisfunktionen sind bedauerlicherweise nicht in der Lage, zwischen Groß- und Kleinschreibung zu unterscheiden.

Wenn Sie diese Unterscheidung bei einer Abfrage benötigen, müssen Sie sich mit einer komplexeren Formel behelfen.

Stellen Sie sich eine Tabelle vor, in der der Suchbegriff in Zelle A1 und die Suchmatrix im Bereich C1:D50 steht. Verwenden Sie dann in der Ergebniszelle die folgende Formel:

=WENN(ODER(IDENTISCH(C1:C50;A1));INDEX(D:D;MAX(IDENTISCH(C1:C50;A1)*ZEILE(1:50)));"")

Bei dieser Formel handelt es sich um eine Matrix-Formel. Deshalb müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE abschließen. Mit UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben.

Eine Abfrage mit Groß- und Kleinschreibung per Excel-Formel

Diese Formel liefert das gewünschte Ergebnis. Wenn der Suchbegriff im Bereich C1:C50 nicht vorkommt, liefert sie eine leere Zelle.

Kommt der Suchbegriff mehr als einmal vor, dann wird der letzte Treffer geliefert.

Beachten Sie: Fängt die Suchmatrix etwa in Zeile 5 an, müssen Sie alles auf 5:50 umstellen, lediglich das Argument für ZEILE muss bei 1 beginnen (1:45).

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"