Ziffern einer Zahl von links nach rechts drehen

13. November 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie Zahlen in Excel-Zellen umdrehen

Stellen Sie sich eine Tabelle vor, in der Sie die Ziffern einer Zahl (beispielsweise einer Bestellnummer) von links nach rechts drehen wollen, aus 123 wird also 321. Für diese Aufgabenstellung können Sie keine der integrierten Funktionen benutzen.

Mit einer Formel, in der Sie die Funktionen SUMMENPRODUKT, TEIL, LÄNGE und ZEILE miteinander kombinieren, kommen Sie zum gewünschten Ergebnis.

Wenn die zu konvertierende Zahl in der Zelle A2 steht, verwenden Sie die folgende Formel:

=SUMMENPRODUKT(TEIL(A2*10^(16-LÄNGE(A2));ZEILE($1:$16);1) *10^(ZEILE($1:$16)-1))

Als Ergebnis liefert diese Formel eine Zahl ohne führende Nullen. Das hat zur Folge, dass rechtsstehende Nullen nicht dargestellt werden. Die folgende Abbildung zeigt den Einsatz der Formel in einer Beispieltabelle:

 

Wenn auch führende Nullen berücksichtigt werden sollen, sieht die Formel folgendermaßen aus

=TEXT(SUMMENPRODUKT(TEIL(A2;ZEILE(INDIREKT("1:"&LÄNGE(A2)));1)*10^(ZEILE(INDIREKT("1:"&LÄNGE(A2)))-1));WIEDERHOLEN("0";LÄNGE(A2)))

Bei dieser Formel handelt es sich um eine Matrix-Formel die Sie mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen müssen. Auch nach jeder Änderung der Formel müssen Sie diese Tastenkombination erneut verwenden, um die Formel zu bestätigen.

Die Formeln arbeiten nur mit ganzen Zahlen ohne Kommastellen, sind also ideal für Seriennummern, Artikelnummern oder ähnliche Anwendungen.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"