Ziffern in Zahlenliste zählen

22. Oktober 2010
Martin Althaus Von Martin Althaus, Excel, Office ...

Wie Sie ermitteln, wie oft bestimmte Ziffern in einer Liste auftreten

Sie möchten feststellen, wie oft bestimmte Ziffern in einer Datengruppe auftauchen? Das kann wichtig sein, um Daten zu klassifizieren oder ihre Plausibilität zu testen.

Schauen Sie sich die Tabelle in der Abbildung an.

Sie möchten feststellen, wie Werte in der Liste A1:A15 es gibt, in der die Ziffer aus Zelle C1 (also die Zwei) mindestens ein Mal auftritt. Um dieses Ziel zu erreichen, setzen Sie eine Matrixformel ein. Kombinieren Sie die Funktion FINDEN mit den Funktionen WENN und SUMME. Über FINDEN suchen Sie nach der gewünschten Ziffer. Die Funktion liefert immer dann das Fehlerergebnis #WERT!, wenn die Zahl nicht gefunden wurde. Daher nutzen Sie das Auftreten des Fehler als Kriterium für die Funktionskombination aus SUMME und WENN.

Setzen Sie die folgende Formel ein, um die Anzahl der Datensätze zu zählen, in denen gesuchte Ziffer aus Zelle C1 auftritt:

=SUMME(WENN(ISTFEHLER(FINDEN(C1;A1:A15));0;1))

Um die Formel einzugeben, verwenden Sie die Tastenkombination STRG UMSCHALT EINGABE. Auch nach jeder Änderung der Formel müssen Sie diese Tastenkombination einsetzen. Mit der Taste UMSCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Wenn Excel die Formel als Matrixformel übernommen hat, können Sie das an den geschweiften Klammern rund um die Formel erkennen. Die folgende Abbildung zeigt den Einsatz dieser Formel in der Praxis:

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"