Anzahl unterschiedlicher Inhalte sicher zählen
© sdecoret - Adobe Stock

Anzahl unterschiedlicher Inhalte sicher zählen

Die Anzahl der unterschiedlichen Einträge in einer Spalte ist die entscheidende Information, die Sie in einer Liste ermitteln möchten. Eine Spezialformel erledigt diese Aufgabe im Handumdrehen auch dann, wenn in der zu untersuchenden Spalte auch leere Zel

So sieht die Formel aus, mit der Sie die Anzahl verschiedener Einträge zählen und dabei leere Zellen unberücksichtigt lassen: 

=SUMME(WENN(HÄUFIGKEIT(WENN(LÄNGE (ZählBer)>0;VERGLEICH(ZählBer;ZählBer;0); ““);WENN(LÄNGE(ZählBer)>0; VERGLEICH(ZählBer;ZählBer;0);““))>0;1))

Sie übergeben der Formel mit ZählBer nur ein Argument: den Spaltenbereich, in dem Sie die Anzahl der unterschiedlichen Inhalte zählen möchten. Die Formel kann nur für einen Spaltenbereich ein korrektes Ergebnis ermitteln. Achten Sie also darauf, dass der übergebene Bereich nur aus einer Spalte besteht.

 Bestätigen Sie die Matrixformel nach der Eingabe über die Tastenkombination Strg+Umschalt+Eingabe. Die Formel liefert als Ergebnis die Anzahl der unterschiedlichen Inhalte im übergebenen Bereich.

In der abgebildeten Arbeitsmappe liefert die folgende Matrixformel in Zelle F3 die Anzahl 9: 

=SUMME(WENN(HÄUFIGKEIT(WENN(LÄNGE(C4:C35) >0;VERGLEICH(C4:C35;C4:C35;0);““); WENN(LÄNGE(C4:C35)>0;VERGLEICH(C4:C35;C4 :C35;0);““))>0;1))

Im übergebenen Bereich C4:C35 treten insgesamt nur neun verschiedene Inhalte auf, obwohl der Bereich aus 32 Zeilen besteht.

 

So trickreich ermittelt die Formel die Anzahl der unterschiedlichen Datzensätze

Die Formel arbeitet nach der folgenden Methode, um die Anzahl der verschiedenen Inhalte festzustellen:

 

  • Die Funktion HÄUFIGKEIT ermittelt die Häufigkeitsverteilung des übergebenen Bereichs.
  • Mit den VERGLEICH-Funktionen ermitteln Sie jeweils die erste Position jedes Inhalts innerhalb des übergebenen Spaltenbereichs.
  • Dadurch liefern alle VERGLEICH-Funktionen auch für mehrfache Inhalte immer die erste Position des Auftretens.
  • Diese jeweils ersten Positionen übergeben Sie der HÄUFIGKEIT-Funktion, sowohl als Daten als auch als Klassen.
  • Die HÄUFIGKEIT-Funktion liefert dadurch nur für jeden unterschiedlichen Inhalt im Spaltenbereich einen Wert von größer als 1.
  • Mit der SUMME-WENN-Kombination summieren Sie diese Einserwerte und zählen somit die verschiedenen Inhalte.
  • Die WENN-LÄNGE-Kombinationen setzen Sie ein, damit die VERGLEICH-Funktionen nur die gefüllten Zellen des Spaltenbereichs berücksichtigen.
  • Über die Funktion LÄNGE ermitteln Sie die Länge der Zellinhalte. Nur wenn ein Zellinhalt eine Länge größer als 0 besitzt, befindet sich auch ein Inhalt in dieser Zelle. Auf diesem Weg erkennen Sie Zellen, die leer sind. Mit der WENN-Funktion setzen Sie diese Unterscheidung als Kriterium ein.