Wie Sie beliebige Zellen und Spalten miteinander in Excel addieren
© sdecoret - Adobe Stock

Wie Sie beliebige Zellen und Spalten miteinander in Excel addieren

Sie möchten nur jede vierte Zeile in Excel addieren? Oder nur jede zweite Spalte? Wir zeigen Ihnen die Formel, die Sie dafür benötigen.

Wie Sie jede zweite Spalte in einer Excel-Tabelle addieren

Stellen Sie sich eine Tabelle vor, in der Sie in Zeilen Summen bilden wollen, bei denen nur jede zweite Spalte berücksichtigt wird. Denken Sie an eine Liste mit Umsätzen, in der an jedem Tag zwei Spalten zugeordnet werden, eine für den Nettoumsatz und eine für die Mehrwertsteuer.

Für die tägliche Addition der Umsätze benötigen Sie eine Formel, die überprüft, ob sich die Werte in Spalten mit gerader Spaltennummer befinden oder nicht. Daraufhin wird der Wert der Summe hinzugefügt oder eben nicht.

Wenn es sich nur um einige wenige Werte handelt, die Sie addieren müssen, können Sie die Zahlen auch einzeln per Pluszeichen verknüpfen, aber was machen Sie in umfangreichen Tabellen? Gehen Sie folgendermaßen vor:

Wenn in der Tabelle die Umsätze des ersten Tages in Zeile 3 erfasst sind, stehen in Zelle B3 die Nettoumsätze des ersten Tages und in Zelle C3 die Mehrwertsteuer dieses Tages.

Die Nettoumsätze erhalten Sie durch Addition der Werte aus geraden Spalten; die Mehr-wertsteuer steht in den ungeraden. Ob eine Spalte gerade oder ungerade ist, erfahren Sie, wenn Sie die Zeilennummer durch 2 teilen und den ganzzahligen Rest betrachten: Bei gerader Spalte ist der Rest Null.

Für die Summe der Nettoumsätze verwenden Sie die folgende Formel:

=SUMME((REST(SPALTE(B3:M3);2)=0)* B3:M3)

Da es sich um eine Matrixformel handelt, müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen. Mit UMCHALT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben einzugeben. Sie wird auch SHIFT genannt.

Für die ungeraden Spalten ersetzen Sie "=0" durch "<>0".

Wie Sie beliebige Zeilen in einer Excel-Tabelle miteinander addieren

Um beispielsweise dafür zu sorgen, beginnend mit der Zelle A1 jede vierte Zelle im Bereich A1 zu addieren, verwenden Sie die folgende Formel:

=SUMME(WENN(REST(ZEILE(A1:A1000);4)=1;A1:A1000))

Damit die Formel funktioniert, müssen Sie sie über die Tastenkombination STRG SHIFT ENTER eingeben (mit SHIFT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch UMSCHALT genannt). Dann stellt Excel die Formel in geschweiften Klammern dar. 

Auch nach einer Änderung der Formel müssen Sie immer die Tastenkombination STRG SHIFT ENTER verwenden, um die Formel einzugeben. Wenn Sie die Addition jeder dritten Zelle vornehmen möchten, ändern Sie die Ziffer 4 in der Formel in den entsprechenden Wert 3.