Prüfen, ob Zellinhalt ein Text oder eine Zahl ist

15. Mai 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

So ermitteln Sie den Typ einer Zelle in Excel

Bei der Arbeit mit einer Excel-Tabelle kann es interessant sein, zu ermitteln, ob es sich bei einem Zellinhalt um einen Text oder eine Zahl handelt. Stellen Sie sich vor, Sie möchten die Anzahl der Zellen ermitteln, deren Inhalt entweder ein Textelement oder ein Wert ist.

Dabei hilft Ihnen eine Matrixformel. Stellen Sie sich beispielsweise eine Tabelle vor, die in den Zellen A1 bis A7 verschiedene Elemente oder nichts enthält. In der Zelle A8 möchten Sie – wie oben beschrieben – die Anzahl ermitteln. Die Formel hat die folgende Form:

=SUMME(WENN(ISTTEXT(A1:A6);1; WENN(ISTZAHL(A1:A6);1;0)))

Da es sich um eine Matrixformel handelt, die nacheinander alle Zellen des angegebenen Bereichs überprüft, müssen Sie die Eingabe mit der Tastenkombination STRG SHIFT ENTER abschließen.

Die Kombination der Funktionen ISTTEXT und ISTZAHL mit einer Wenn-Abfrage ermöglicht die Unterscheidung zwischen Texten und Zahlen.

Die Formel arbeitet folgendermaßen:

     

  1. Als Erstes wird überprüft, ob in den Zellen des angegebenen Bereiches ein Text enthalten ist. Wenn ja, wird zu der bisherigen Summe der Wert 1 addiert.
  2. Wenn nicht, wird überprüft, ob in der Zelle des angegebenen Bereichs eine numerische Zahl enthalten ist.
  3. Ist dies der Fall, wird zu der bisherigen Summe eine 1 addiert, ansonsten eine 0.
  4.  

Mit dieser Matrixformel ermitteln Sie daher die Anzahl der Zellen, die entweder einen Text oder eine Zahl enthalten.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"