Identische Inhalte? Wie sie zwei Spalten einer Tabelle vergleichen

28. Februar 2008
Martin Althaus Von Martin Althaus, Excel, Office ...

Mit einer Formel Spalten schnell miteinander vergleichen

Wer häufig mit Listen in Tabellen arbeitet, kennt die Notwendigkeit, Spalten darauf zu überprüfen, ob ihre Inhalte identisch sind.

Stellen Sie sich eine Tabelle vor, in der in den Spalten A und B in den Zeilen 1 bis 20 Namenslisten stehen, die miteinander verglichen werden sollen. Wenn der Inhalt beider Listen gleich ist, soll in einer Zelle der Text "identisch" ausgegeben werden, und wenn der nicht gleich ist, "nicht identisch".

Dazu benötigen Sie eine Formel, die die absolute Identität beider Listen überprüft, unter Berücksichtigung von Groß- und Kleinschreibung.

Geben Sie in die Zelle, in der die Information ausgegeben werden soll, ob die Listen identisch sind oder nicht, die folgende Formel ein:

=WENN(UND(IDENTISCH(A1:A20;B1:B20));"";"nicht ")&"identisch"

Da es sich bei dieser Formel um eine Matrixformel handelt, die einen Zellbereich durchsucht, müssen Sie die Eingabe der Formel mit der Tastenkombination STRG SHIFT ENTER bestätigen (mit SHIFT ist die Taste gemeint, die Sie gedrückt halten müssen, um einen Großbuchstaben zu erreichen, diese Taste wird auch UMSCHALT genannt).

Die Formel wird daraufhin automatisch in geschweifte Klammern gesetzt.

Bei Excel ab Version XP können Sie die Formel auch ohne die Tastenkombination eingeben und stattdessen ENTER drücken.

Die folgende Abbildung zeigt den Einsatz der Formel zum Vergleich von zwei Spalten an einem Beispiel:

excel tabelle

Auch nach einer Änderung der Formel müssen Sie immer die Tastenkombination STRG SHIFT ENTER verwenden, um die Formel einzugeben.

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

  • Excel Vorlagen zum Sofort-Download
  • Geprüfte Vorlagen zum Sofort-Einsatz
  • Gratis Makros & Add-Ins im Downloadcenter
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"