So stimmt die Reihenfolge der Datensätze
So stimmt die Reihenfolge der Datensätze

Excel-Tabellen über Formeln automatisch sortieren

Indem Sie Listen per Formel sortieren, erhalten Sie eine neue Reihenfolge der Daten, sobald sich Quelldaten in der Liste verändern - und das ganz ohne den Aufruf eines Kommandos

In einer Tabelle stehen in einer Spalte Textwerte in unsortierter Reihenfolge. Diese sollen in einer anderen Spalte sortiert ausgegeben werden.  Diese Aufgabe können Sie mit einem Spezialfilter lösen. Häufig ist der Weg über eine Formel allerdings komfortabler und flexibler. Das gilt vor allem dann, wenn sich Daten verändern. Beim Sortieren per Formel müssen sie den Sortiervorgang nicht manuell starten, die Formeln halten die Liste immer automatisch sortiert.

In der Beispieltabelle stehen in der Spalte A in den Zeilen 1 bis 7 die Wochentage in chronologischer Reihenfolge. Diese sollen in alphabetischer Reihenfolge in einem anderen Zellbereich ausgegeben werden, im vorliegenden Beispiel im Bereich C1:C7, da die Spalte B als Hilfsspalte benötigt wird.

Die folgende Abbildung zeigt den Aufbau der Beispieltabelle:

Diese Tabelle per Formel sortieren

Für die Sortierung verwenden Sie die Spalte B als Hilfsspalte. In die Zelle B1 tragen Sie die folgende Formel ein:

=SUMME(WENN(A$1:A$7 < A1;1))+ (A1="")*1000

Da es sich um eine Matrixformel handelt, die den Zellbereich A1:A7 durchsucht, müssen Sie die Eingabe der Formel mit STRG UMSCHALT EINGABE  bestätigen.

Die Formel in der Zelle B1 kopieren Sie anschließend nach unten bis zur Zelle B7.

Die folgende Abbildung zeigt den Einsatz der Formel in der Hilfsspalte in der Beispieltabelle:

Der Einsatz der Formel in der Hilfsspalte

Für das Sortieren der Wochentage in der Spalte C tragen Sie die folgende Formel in die Zelle C1 ein:

=INDIREKT("A"&VERGLEICH(KKLEINSTE(B$1:B$7;ZEILE());B$1:B$7;0))

Da es sich auch hier um eine Matrixformel handelt, die den Zellbereich B1:B7 berücksichtigt, müssen Sie die Eingabe mit der Tastenkombination STRG UMSCHALT EINGABE bestätigen.

Anschließend kopieren Sie die Formel aus Zelle C1 nach unten bis zur Zelle C7.

Die folgende Abbildung zeigt das Ergebnis der Formelsortierung in der Beispieltabelle:

So stimmt die Reihenfolge der Datensätze

Wenn Sie die Hilfsspalte B nicht benötigen, können Sie sie auch ausblenden. Dafür markieren Sie die Spalte und klicken den Spaltenkopf mit der rechten Maustaste an. Aus dem erscheinenden Kontextmenü rufen Sie den Befehl AUSBLENDEN auf.