Nullwerte in Excel-Tabellen als leere Zellen anzeigen

15. April 2011
Martin Althaus Von Martin Althaus, Excel, Office ...

So sorgen Sie dafür, Nullen in Ihren Zellen nicht anzuzeigen, sondern stattdessen leere Zellen zu erzeugen

Die Zahl 0 führt zu einer leeren Zelle

Die Zahl 0 führt zu einer leeren Zelle

In der Excel-Praxis gibt es immer wieder Situationen, in denen bei Berechnungen statt des Werts Null eine leere Zelle oder ein anderes Zeichen (beispielsweise ein Strich) in der entsprechenden Zelle ausgegeben werden soll. Das erreichen Sie am besten über den Einsatz der Tabellenfunktion WENN.

Stellen Sie sich eine Tabelle vor, in der Sie in der Zelle A3 den Inhalt der Zelle A2 vom Inhalt der Zelle A1 subtrahieren wollen. Wenn das Ergebnis der Subtraktion null ist, soll die Zelle A3 leer bleiben. Um das zu erreichen, verwenden Sie in Zelle A3 die folgende Formel:

=WENN(A2-A1=0;"";A2-A1)

Diese Formel prüft, ob das Ergebnis der Subtraktion null ist. Wenn ja, wird durch die doppelten Anführungsstriche eine leere Zelle geliefert. Bei der Eingabe der Formel müssen Sie darauf achten, dass die beiden Anführungszeichen unmittelbar hintereinander stehen.

Die folgende Abbildung zeigt das Ergebnis, wenn die Differenz tatsächlich die Zahl Null ergibt:

Die Zahl 0 führt zu einer leeren Zelle

Wenn das Ergebnis einen anderen Wert liefert, wird die Subtraktion durchgeführt und das Ergebnis ausgegeben.

Nur bei einer Differenz ungleich null ist das Ergebnis zu sehen

Statt der leeren Zelle können Sie für die Null auch ein beliebiges anderes Zeichen ausgeben lassen. Das gewünschte Zeichen setzen Sie dann in der WENN-Abfrage zwischen die Anführungsstriche. Für die Ausgabe eines Strichs anstelle der Null sieht die Formel dann folgendermaßen aus:

=WENN(A2-A1=0;"-";A2-A1)

Werden Sie mit unseren Tipps zum Excel-Profi!

Jetzt gratis per E-Mail

DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Weitere Artikel zum Thema

Newsletter

Jetzt kostenlose Excel-Hilfe anfordern!

  • die besten Tipps
  • völlig kostenlos
  • jederzeit abbestellbar
DDV Ehrencodex E-Mail-Marketing
  • Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters.
  • Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter.
  • Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Datenschutzgarantie:

Wir benötigen Ihre E-Mail-Adresse für die Zusendung des Newsletters. Wir geben Ihre E-Mail-Adresse garantiert nicht an Dritte weiter. Jederzeit abbestellbar durch einen Link im Newsletter.

Unsere Experten

Rudolf Ring twittert für @Computerwissen

Die von Ihnen eingegebene E-Mail Adresse ist nicht korrekt. Bitte korrgieren Sie Ihre Eingabe und klicken Sie auf "OK":

Bitte wählen Sie mindestens einen Newsletter aus und klicken Sie auf "OK"