In Excel Bezug auf Zelle im anderen Blatt der gleichen Mappe herstellen und Berechnungen duchführen
© ASDF - Adobe Stock

In Excel Bezug auf Zelle im anderen Blatt der gleichen Mappe herstellen und Berechnungen duchführen

So stellen Sie in Excel einen Bezug auf eine Zelle in einem anderen Tabellenblatt der gleichen Mappe her und führen blattübergreifende Berechnungen durch.

Gerade bei der Arbeit mit Formeln und Funktionen in größeren Mappen benötigen Sie sicher auch manchmal einen Bezug auf eine Zelle in einem anderen Blatt der aktiven Mappe. Das ist vor allem bei Berechnungen von Werten, die sich in verschiedenen Tabellen einer Arbeitsmappe befinden, der Fall.

Wenn Sie Daten in mehr als einer Excel-Tabellen benötigen, müssen Sie diese nicht mühsam neu eintippen oder per Copy & Paste in die entsprechenden Zellen und Spalten transferieren. Wir zeigen Ihnen in diesem Artikel, wie Sie Excel-Tabellen stattdessen ganz einfach miteinander verknüpfen können und Berechnungen so über mehrere Tabellenblätter hinweg durchführen können.

Anleitung: So stellen Sie die Verknüpfung zwischen zwei Excel-Tabellen her

Die Verknüpfung zwischen zwei Excel-Tabellen stellen Sie über eine Formel und einen externen Bezug in der Ziel-Tabelle her: Öffnen Sie dazu als erstes die beiden Tabellen, die Sie miteinander verknüpfen möchten. Klicken Sie dann in der Ziel-Tabelle die Zelle an, in der Sie die Daten aus der Quell-Datei anzeigen möchten. In unserem Beispiel handelt es sich dabei um die Zelle B1.

 

Hier soll nun aus unserer Quell-Tabelle die Mitarbeiter-Zahl aus der Passauer Filiale angezeigt werden.

Die Formel für die Verknüpfung wird immer mit einem Gleichheitszeichen eingeleitet. Tippen Sie „=“ in die vorher ausgewählte Zelle ein.

Sie können einen solchen Bezug entweder mit der Maus erzeugen, oder über die Tastatur direkt eingeben.

Wenn Sie sich innerhalb einer Funktion oder Formel an einer Position befinden, an der ein Bezug erwartet wird (z.B. nach der Eingabe eine Gleichheitszeichens in einer Zelle), klicken Sie das gewünschte Tabellenblatt und dann die gewünschte Zelle an. Dann legt Excel den Bezug automatisch an.

Falls Sie den Bezug über die Tastatur erzeugen möchten, verwenden Sie die folgende Syntax:

=Blattname!Zelle

Für Blattname geben Sie den Namen des Blattes ein, auf dessen Zelle Sie Bezug nehmen möchten. Zelle legt den Bezug auf die Zelle(n) in der Tabelle Blattname fest, auf die Sie Bezug nehmen möchten.

Die folgende Eingabe nimmt zum Beispiel Bezug auf die Zelle B1 im Blatt "Mitarbeiter":

=Mitarbeiter!B1

 

So führen Sie Berechnungen über mehrere Excel-Tabellenblätter durch

In einer Arbeitsmappe befinden sich mehrere Tabellenblätter, die identisch aufgebaut sind. In einem Zusammenfassungsblatt sollen nun Berechnungen über alle Blätter vorgenommen werden – beispielsweise Summen oder Maximalwerte.

Die grundsätzliche Möglichkeit, Berechnungen über mehrere Tabellenblätter einer Arbeitsmappe durchzuführen, ist den meisten Anwendern bekannt und wird rege genutzt.

Dass dabei auch Bereiche übergeben werden können, die die Formeln deutlich verkürzen und übersichtlicher machen, wissen nur wenige. Für den Einsatz tabellenübergreifender Bereiche gehen Sie folgendermaßen vor:

Stellen Sie sicher, dass alle Tabellenblätter, die Sie für Ihre Berechnungen brauchen, identisch aufgebaut sind. Nur dann liefern die Formeln die korrekten Ergebnisse.

Bedenken Sie, dass es im Ergebnis nicht unbedingt auffallen muss, wenn der Datenbereich in einem der Blätter um eine Zeile oder Spalte verschoben ist.

Im vorliegenden Beispiel sollen für einen Vergleich Berechnungen über sieben Tabellenblätter durchgeführt werden, in denen ältere Produktionszahlen der Jahre 2002 bis 2008 erfasst sind.

Die folgende Abbildung zeigt den Aufbau der einzelnen Blätter:

Neben dem einheitlichen Aufbau der Tabellen ist die Anordnung der Blätter in der Arbeitsmappe wichtig. Stellen Sie sicher, dass die benötigten Tabellenblätter in der Arbeitsmappe nebeneinanderliegen.

Die folgende Abbildung zeigt die Anordnung der Tabellenblätter in der Beispielarbeitsmappe:

Wenn die Vorbereitungen abgeschlossen sind, können Sie mit der Eingabe der Formeln beginnen.

So berechnen Sie die Summe mehrerer Tabellenblätter von Excel

In der Beispieltabelle soll in einem Zusammenfassungsblatt die Summe aller Jahressummen ermittelt werden. Die Summen der einzelnen Jahre stehen in den entsprechenden Tabellen jeweils in der Zelle H16.

Die dazu benötigte Formel besitzt den folgenden Aufbau:

=SUMME('ErstesBlatt:LetztesBlatt'!Bereich)

Mit "ErstesBlatt" übergeben Sie den Namen des ersten Blattes das in die Berechnung einfließen soll. Das Argument "LetztesBlatt" definiert den Namen des letzten Blattes für die Berechnung. Alle zwischen diesen beiden Blättern liegenden Blätter werden ebenfalls berücksichtigt. Über "Bereich" definieren Sie den Bereich, den Sie summieren möchten.

Mit der folgenden Formel errechnen Sie nun die Summe der Werte in den Zellen H16 der Tabellenblätter 2002 bis 2008:

=SUMME('2002:2008'!H16)

Die folgende Abbildung zeigt den Einsatz dieser Formel in der Beispieltabelle:

Auf diese Art und Weise können Sie auch andere Zellen abfragen. Dabei können Sie bei Bedarf auch andere Funktionen verwenden, denen Bereiche als Argument übergeben werden.

Bei der Berechnung über mehrere Tabellenblätter sind Sie nicht auf einzelne Zellen in den angesprochenen Tabellen beschränkt. Sie können auch dort Bereiche an eine Funktion übergeben.

So berechnen Sie den Maximalwert mehrerer Tabellenblätter von Excel

In der Beispieltabelle soll der absolute Höchstwert aller Einzelwerte aller Jahre ermittelt werden. Die Einzelwerte stehen in den Tabellen 2002 bis 2008 in den Zellen B4:G15.

Mit der folgenden Formel ermitteln Sie den Maximalwert aller Einzelwerte über die sieben Tabellenblätter der entsprechenden Jahre:

=MAX('2002:2008'!B4:G15)

Die folgende Abbildung zeigt den Einsatz dieser Formel in der Beispieltabelle:

Auch der Mittelwert lässt sich über mehrere Blätter hinweg berechnen. Dazu gehen Sie wie folgt vor:

=MITTELWERT(‘Startblatt:Endblatt’!ZellBer)

Sie übergeben der Formel drei Argumente: Mit Startblatt übergeben Sie den Namen des ersten Blatts, das in die Berechnung einfließen soll. Über Endblatt definieren Sie den Namen des letzten Blattes für die Berechnung. Alle zwischen diesen beiden Blättern liegenden Blätter fließen in die Berechnung ein. Über ZellBer definieren Sie den Zellbereich für die Berechnung.

So berechnen Sie den Mittelwert mehrerer Tabellenblätter von Excel

Auch der Mittelwert lässt sich über mehrere Blätter hinweg berechnen. Dazu gehen Sie wie folgt vor:

=MITTELWERT(‘Startblatt:Endblatt’!ZellBer)

Sie übergeben der Formel drei Argumente: Mit Startblatt übergeben Sie den Namen des ersten Blatts, das in die Berechnung einfließen soll. Über Endblatt definieren Sie den Namen des letzten Blattes für die Berechnung. Alle zwischen diesen beiden Blättern liegenden Blätter fließen in die Berechnung ein. Über ZellBer definieren Sie den Zellbereich für die Berechnung.

Wie lassen sich Werte aus anderen Dokumenten verknüpfen?

Manchmal müssen Sie in Excel Zellbezüge aus einem anderen Tabellenblatt verknüpfen, die sich nicht im selben Dokument befinden. Dafür müssen Sie den oben beschriebenen Zellbezug nur um den Namen des Dokuments erweitern. Dieser wird mit eckigen Klammern („[“ bzw. „]“) gekennzeichnet.

Beispiel:
=[Dokument1]Ursprung!G9

Diese Variante verwenden Sie, wenn die andere Mappe mit dem Namen „Dokument1“ geöffnet ist. Wenn das Dokument nicht geöffnet ist, verwenden Sie hingegen den Pfad, unter dem es gespeichert ist.

Beispiel:
=C:\Dateien\Ordnername\[Dokument1]Ursprung!G9

    Fehler im Zellbezug

    Wenn Sie Excel keine eindeutigen Befehle geben, kann es zu einem Bezugsfehler kommen. So kann eine Zelle immer nur genau eine Zelle als Bezugsgröße haben. Ist dies nicht der Fall, ist höchstwahrscheinlich beim markieren des Bereiches mit der Maus ein Fehler passiert.
    Ein Bezugsfehler tritt auch auf, wenn ein Zellbezug zu einem anderen Tabellenblatt eingetragen war, dieses Tabellenblatt wurde jedoch gelöscht, oder umbenannt. Vergleichbar mit der Zustellung zu einer Adresse würde dann die Postleihzahl nicht mehr stimmen.